Search found 43 matches

by nabsltd
Sun Apr 23, 2017 3:36 pm
Forum: FontCreator - Support
Topic: Wrong outlines loaded
Replies: 4
Views: 32

Re: Wrong outlines loaded

This is not a bug in FontCreator. The italic flag is enabled in Font Properties. OK, so then the FontCreator bug is that the preview on FontCreator doesn't show the font in italics, like every other program does. Also, the "test current font as TTF/OTF" view doesn't show the italics. Both...
by nabsltd
Wed Apr 19, 2017 3:51 pm
Forum: FontCreator - Support
Topic: Wrong outlines loaded
Replies: 4
Views: 32

Wrong outlines loaded

When opening the attached font file with FontCreator 10.1.0, the outlines are not the ones that appear to be in the font from all other ways of looking at it. Here's the font as it appears in MainType: MainTypeView.jpg And, here is it opened in FontCreator: FontCreatorView.jpg My only thought was th...
by nabsltd
Mon Mar 27, 2017 1:03 am
Forum: FontCreator - Bug Reports
Topic: PANOSE not saved correctly for Latin Symbol fonts.
Replies: 2
Views: 156

Re: PANOSE not saved correctly for Latin Symbol fonts.

Only set it for legacy Symbol fonts, otherwise your font will fail to work. OK, but that doesn't change the fact that even on fonts like that (by which you mean the normal A-Z alphabet code points are replaced with symbols that don't look like letters), the same thing happens. You should be able to...
by nabsltd
Sun Mar 26, 2017 2:52 am
Forum: FontCreator - Bug Reports
Topic: PANOSE not saved correctly for Latin Symbol fonts.
Replies: 2
Views: 156

PANOSE not saved correctly for Latin Symbol fonts.

FontCreator 10.1.0 doesn't correctly save the PANOSE information for a font if the first digit is "5" (Latin Symbol/Pictorial). After you make changes to the PANOSE and set the Family Kind to "5" and click OK, it looks like the change is saved on repeated opening of the Font Prop...
by nabsltd
Thu Mar 09, 2017 5:46 pm
Forum: FontCreator - Bug Reports
Topic: "Extended" Font Properties not saving
Replies: 6
Views: 166

"Extended" Font Properties not saving

No matter what you enter for "Typographic Family" and "Typographic Subfamily" on the "Extended" tab of the "Font Properties" dialog, it reverts to whatever was there before. This means that you can't set these for a new project (where they start out blank) and...
by nabsltd
Wed Jan 04, 2017 10:42 pm
Forum: FontCreator - Bug Reports
Topic: Successive open/export cycles cause CFF outlines to change
Replies: 3
Views: 142

Re: Successive open/export cycles cause CFF outlines to change

Project files are what you should be saving and opening to make your changes. Period. I don't create my own fonts, so I can't do this. I have to start with an existing .OTF or .TTF file. Still, the load/save of outlines isn't deterministic. This means that if you lose your project file, you are com...
by nabsltd
Sat Dec 24, 2016 2:26 am
Forum: FontCreator - Bug Reports
Topic: Successive open/export cycles cause CFF outlines to change
Replies: 3
Views: 142

Successive open/export cycles cause CFF outlines to change

1. Open a font with PostScript outlines. 2. Export the font without making any changes, and note that the file size has grown dramatically if you start with most commercial fonts. 3. Delete the original file, open the exported file, and export it to a new file...again, the file grows. 4. Repeat a fe...
by nabsltd
Sat Dec 24, 2016 1:45 am
Forum: FontCreator - Bug Reports
Topic: [FIXED] Exported font with FontCreator causes errors when printing
Replies: 10
Views: 319

Re: Exported font with FontCreator causes errors when printing

Erwin Denissen wrote:We released a new version yesterday which solves the problem. Do let us know your results as well, to confirm it. Thank you!

This did solve the problem, but I've posted another bug related to this.
by nabsltd
Wed Dec 07, 2016 7:07 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] OpenType CFF font files take forever to open
Replies: 12
Views: 428

Re: OpenType CFF font files take forever to open

The update released earlier today solves the issue. Definite fix...it's much, much faster than even 10.0 opened the fonts. Because it is aimed at modifying fonts, and since FontCreator currently only supports quadratic bezier curves, all cubic curves need to be converted. Despite the speed increase...
by nabsltd
Wed Dec 07, 2016 6:52 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] Exported font with FontCreator causes errors when printing
Replies: 10
Views: 319

Re: Exported font with FontCreator causes errors when printing

All fonts print just fine here. We're using a HP Color LaserJet Pro MFP M476dw. The default driver for HP printers is the PCL6 driver. That is what is installed if you use Windows Update or "find a driver on the Internet" to install. As I said, this driver works fine. Only the PostScript ...
by nabsltd
Sat Dec 03, 2016 7:27 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] OpenType CFF font files take forever to open
Replies: 12
Views: 428

Re: OpenType CFF font files take forever to open

It is slower because we improved accuracy while keeping the number of points as low as possible. Now that I've wasted a lot more time waiting out the nearly two-hour load time for some fonts, I've realized a few things. First, why is FontCreator doing anything at all with the outlines on font open?...
by nabsltd
Sat Dec 03, 2016 6:53 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] Exported font with FontCreator causes errors when printing
Replies: 10
Views: 319

Re: Exported font with FontCreator causes errors when printing

I assume you tested with FontCreator 10.1? No, I hadn't, but now I've spent a lot more time on this to rule out some things. Since a project saved with 10.0 and then re-opened with 10.1 opens much faster than the original CFF font file in 10.1, I tried that. When I did, I found out that 10.1 would ...
by nabsltd
Fri Dec 02, 2016 9:11 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] Exported font with FontCreator causes errors when printing
Replies: 10
Views: 319

[FIXED] Exported font with FontCreator causes errors when printing

I have an HP Color LaserJet M533dn, and fonts saved with FontCreator don't print correctly: PrintedFontBug.jpg This is Adobe's Garamond Premier Pro using the font file as it came from Adobe, and the font file created by FontCreator 10.0 after opening the original .OTF then saving it with no changes....
by nabsltd
Wed Nov 30, 2016 7:00 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] OpenType CFF font files take forever to open
Replies: 12
Views: 428

Re: OpenType CFF font files take forever to open

It is slower because we improved accuracy while keeping the number of points as low as possible. The accuracy can't be enough improved to warrant the 20 to 30 times increase in load time. It also means that drag and drop to open is pretty unusable, as the Explorer window is unresponsive until FontC...
by nabsltd
Wed Nov 30, 2016 5:12 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] OpenType CFF font files take forever to open
Replies: 12
Views: 428

[FIXED] OpenType CFF font files take forever to open

In FontCreator 10.1, pretty much every font with PostScript outlines now takes 20 to 30 times as long to open as in 10.0: 10.0 10.1 Adobe AachenStd-Bold.otf 0:05 1:15 Storm Aahoj.otf 0:02 1:09 GNU FreeSerif-Regular.otf 0:24 5:00 (gave up and killed the process) Fonts with TrueType outlines don't see...

Go to advanced search