Page 1 of 1

MainType 6.0 Installation Error

Posted: Tue Mar 14, 2017 8:05 pm
by ChrisW828
I want to keep using MainType 6 because I can't afford an upgrade right now. I accidentally installed MainType 7, uninstalled it, and installed MainType 6. I get an error when I try to run it now, though: Handshake error: Client protocol version is too low. Make sure you are starting the correct version.

What must I uninstall or clean out to fix this problem?

TIA

Re: MainType 6.0 Installation Error

Posted: Wed Mar 15, 2017 11:45 am
by Erwin Denissen
It can be done, but since older versions don't overwrite all more recent components (we try to move forward), it needs to be done with care.

Please be aware the MainType database is upgraded to support MainType 7. This can't be reverted to an older version, so you will loose all your font libraries, groups, tags, settings, etc. You can of course restore a backup if you did make a version 6 backup through FmsConfig.

To get up and running with a clean previous version of MainType, you need to fully uninstall MainType 7 through Windows regular uninstall feature.

In Windows 10 open the Settings menu (Start -> Settings) and go to System and then click Apps & features. Here is the Dutch version:
uninstallapps.png
uninstallapps.png (41.14 KiB) Viewed 36 times


Then remove MainType 7. You will need to fully remove it,
uninstallmt.png
uninstallmt.png (4.79 KiB) Viewed 36 times


And also let it remove the database, vault, and cache files.
uninstallmtfull.png
uninstallmtfull.png (5.38 KiB) Viewed 36 times


It is possible Windows still thinks one or more DLLs are in use, so you have to delete those manually:
C:\WINDOWS\system32\hlfontlib.dll
C:\Program Files (x86)\High-Logic FontService\sqlite3.dll

Finally install your older copy of MainType.

Note: If for some reason you didn't follow the above steps, then it might be best to first reinstall version 7, and then start all over with the above explained reinstall process.