Font loading and Inkscape

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Ahnìon
Posts: 3
Joined: Wed Dec 23, 2020 7:06 pm
Location: Norrköping, Sweden

Font loading and Inkscape

Post by Ahnìon »

I've recently started using MainType and am trying to get the font loading function to work with Inkscape without luck. Loaded fonts seem to show up fine in other applications, but not in Inkscape.

Being cross-platform, Inkscape quite likely has some nonstandard solutions, and as I'm unclear of how the MainType service achieves its injection into the Windows font management system, it's a bit hard to figure out exactly what the problem is.

Has anyone gotten MainType's font loading feature to work with Inkscape, or is it a lost cause?
Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 9123
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Font loading and Inkscape

Post by Bhikkhu Pesala »

Most applications should detect newly installed fonts. I am not sure about fonts that are just Loaded and not Installed. It may be necessary to restart Inkscape to detect the new fonts. I no longer have Inkscape installed to test this.

Loaded fonts are not available after rebooting Windows, but installed fonts are.

Install and Load Fonts.
My FontsReviews: MainTypeFont CreatorHelpFC13 Pro + MT10.0 @ Win10 2004 build 19041.867
Ahnìon
Posts: 3
Joined: Wed Dec 23, 2020 7:06 pm
Location: Norrköping, Sweden

Re: Font loading and Inkscape

Post by Ahnìon »

Thanks for the quick answer!

Inkscape has a timed reload for fonts (I think it's at 30 seconds) so a program restart shouldn't really be necessary. I have tried it though, and it makes no difference if I load fonts before starting Inkscape. Installed fonts show up as usual, but loaded ones don't.

Installing fonts on a project by project basis works fine, of course. It's just that the font loading feature is so neat it seems a shame not to use it if it's possible.

I sort of suspect that Inkscape does some sort of unconventional direct scanning and loading of fonts. While researching the issue, I found references to it loading "deleted" fonts from hidden directories.
Last edited by Ahnìon on Wed Dec 23, 2020 9:08 pm, edited 1 time in total.
Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 9123
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Font loading and Inkscape

Post by Bhikkhu Pesala »

A workaround would be to create font groups in MainType for different Inkscape projects. Then you can install and uninstall the entire group of fonts at once.
My FontsReviews: MainTypeFont CreatorHelpFC13 Pro + MT10.0 @ Win10 2004 build 19041.867
Ahnìon
Posts: 3
Joined: Wed Dec 23, 2020 7:06 pm
Location: Norrköping, Sweden

Re: Font loading and Inkscape

Post by Ahnìon »

Yes, project-based groups is how I plan to work with MainType regardless of whether or not I can get Inkscape to accept loaded fonts. It's probably the most sensible way of managing a large font library, and I'm glad there's a font manager that has this sort of functionality.
Sleen
Posts: 7
Joined: Tue Dec 29, 2020 9:21 pm

Re: Font loading and Inkscape

Post by Sleen »

I'm having a problem with Inkscape as well.

Ever since I started using MT, I cannot use any font except the ones that came pre-installed on my computer (Windows 10).

I have tried loading fonts (did not work) and I also tried installing them (did not work). I have re-started Inkscape after installing a font. Still nothing.

I have confirmed that the newly-installed font exists in C:\Windows\Fonts.

Other programs are able to use the fonts whether loaded OR installed, but I can't get Inkscape to work with them at all. The font-name appears on the Inkscape font drop-down list, but with a warning icon and the message "File not found on system".

Any insight?

Celine
Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 9123
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Font loading and Inkscape

Post by Bhikkhu Pesala »

Try rebooting your computer after installing fonts. Loaded fonts will not be available to any applications after a reboot. Restarting Inkscape should be sufficient, but if not, a reboot should do it.
My FontsReviews: MainTypeFont CreatorHelpFC13 Pro + MT10.0 @ Win10 2004 build 19041.867
Erwin Denissen
Moderator
Moderator
Posts: 9359
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Font loading and Inkscape

Post by Erwin Denissen »

Sleen wrote: Tue Mar 30, 2021 11:59 pm I'm having a problem with Inkscape as well.
It is a limitation of Inkscape.
Sleen wrote: Tue Mar 30, 2021 11:59 pm I have confirmed that the newly-installed font exists in C:\Windows\Fonts.
Don't just look at the Windows fonts folder to think fonts actually reside in it, as Windows uses an internal font manager to show all installed fonts, even ones that are stored in other locations.
WindowsFontsFolder.png
WindowsFontsFolder.png (323.85 KiB) Viewed 296 times
To reveal the actual location, look in the Information panel inside MainType to inspect the Resources.
MainTypeResource.png
MainTypeResource.png (218.9 KiB) Viewed 296 times
In case you installed the font manually or through another font manager, it might point to another folder. Then this trick usually helps:

Uninstall the font through MainType and then reinstall it through MainType.

Let us know your results.
Erwin Denissen
High-Logic
Proven Font Technology
Sleen
Posts: 7
Joined: Tue Dec 29, 2020 9:21 pm

Re: Font loading and Inkscape

Post by Sleen »

Thanks for your replies.
I did reboot, and then unloaded some fonts and then installed through MT.
Inkscape seems to be working as expected, now.

I'm very relieved! Thanks again.

Celine
Post Reply