Error: Lost Connection to Font Service

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Sleen
Posts: 7
Joined: Tue Dec 29, 2020 9:21 pm

Error: Lost Connection to Font Service

Post by Sleen »

Having trouble.
When I minimize MT to the TaskBar (Windows10, virus-protected) it will not re-open. To get it to work again, I have to start the Windows Task Manager and "End Task" on MT.

I am using the Pro edition.

While trying to figure this out, MT sometimes displayed an "Oops" screen that warned that "MT Lost connection to the font service." I tried running FMSConfig but the strange behavior persists. Reboot changes nothing.

Any ideas?

Celine
Erwin Denissen
Moderator
Moderator
Posts: 9337
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Error: Lost Connection to Font Service

Post by Erwin Denissen »

There has been one fix that might solve the problem. Do download and install this update and let us know your results.

https://www.high-logic.com/tmp/maintype ... 57-x64.exe
Erwin Denissen
High-Logic
Proven Font Technology
Sleen
Posts: 7
Joined: Tue Dec 29, 2020 9:21 pm

Re: Error: Lost Connection to Font Service

Post by Sleen »

I ran the program linked in the previous message.
Now when I minimize MT, the icon doesn't appear in the task bar at all (previously, the icon appeared but clicking it did nothing).
Even worse, using the Windows Task Manager to "End Task" on MT no longer helps. Now I have to reboot the machine to get MT to work again.


Celine
Erwin Denissen
Moderator
Moderator
Posts: 9337
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Error: Lost Connection to Font Service

Post by Erwin Denissen »

It is hard to tell why it fails so badly.

Are you running MainType with the default theme? If not, do set it to Default and see if that solves the problem.
Erwin Denissen
High-Logic
Proven Font Technology
Sleen
Posts: 7
Joined: Tue Dec 29, 2020 9:21 pm

Re: Error: Lost Connection to Font Service

Post by Sleen »

I had not been using the default theme. I switched to the default just now, and rebooted. What is happening now is better, but still not what is expected.

Now when I minimize MT, its taskbar icon disappears completely. I can, however, relaunch from the start menu w/o invoking the Task Manager, and w/o rebooting. So that's an improvement.

Celine
Erwin Denissen
Moderator
Moderator
Posts: 9337
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Error: Lost Connection to Font Service

Post by Erwin Denissen »

It is good to know this helps.

Do you have the Minimize to System Tray option enabled? If so, do uncheck the tickbox.
mtminimize.png
mtminimize.png (39 KiB) Viewed 610 times
Erwin Denissen
High-Logic
Proven Font Technology
Sleen
Posts: 7
Joined: Tue Dec 29, 2020 9:21 pm

Re: Error: Lost Connection to Font Service

Post by Sleen »

I have un-ticked the box, and it seems to be working as expected now!
Thank you very much for your help.

Celine
Post Reply