MainType and Windows 7

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
tobiaspete
Posts: 1
Joined: Wed Sep 02, 2009 8:50 pm

MainType and Windows 7

Postby tobiaspete » Wed Sep 02, 2009 9:08 pm

I am new to MainType, and am trying out the trial version of the software and looking to buy it soon. It looks like it meets my needs quite well. It's difficult to find good font management progams on Windows. I had been using an old version of Suitcase, but Extensis has let it languish too long. So I am trying out MainType and I like it very much so far.

I have encountered one problem. I have installed it within my new Windows 7 (RTM) installation and MainType works really well within it. The problem I am coming up against is...every few days a couple of my fonts get corrupt and no longer appear within Windows once I "Install" from MainType. Maintype installs and displays these fonts correctly, but the Windows system will not and they don't show up in any selection menus. The fonts that get corrupted seem to be the same fonts time after time (Malbeck, Alexa, Helvetica, and Bickham Script), so I am not sure if the problem is Windows 7, the fonts themselves, or MainType. The fonts work for a while, and once I delete and re-add them from the original file, they work again. Sometimes it's even enough to send the files to the Recycle Bin, then manually drag them back onto my desktop and re-add to MainType.

One step I am attempting in the meanwhile, to isolate the problem, is to manually install them to the Windows 7 system, outside of MainType and see if the corruption persists. But I thought I would probe it here too. If I have to do workarounds, or if Windows 7 might not be fully supported, I may hold off on my purchase.

Thanks for any help you can give, I am very pleased with your software otherwise!

Erwin Denissen
Moderator
Moderator
Posts: 6567
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: MainType and Windows 7

Postby Erwin Denissen » Thu Sep 03, 2009 10:51 am

Are those fonts OpenType fonts?
Erwin Denissen
High-Logic
Proven Font Technology

mwookie
Posts: 1
Joined: Thu Feb 04, 2010 8:40 pm

Re: MainType and Windows 7

Postby mwookie » Thu Feb 04, 2010 8:42 pm

I am having issues with Windows 7 and showing open type fonts in MainType. Is this a known issue:? Is there a workaround or fix planned? Thanks.

Erwin Denissen
Moderator
Moderator
Posts: 6567
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: MainType and Windows 7

Postby Erwin Denissen » Fri Feb 05, 2010 11:24 am

Our computers are running Windows 7 and we have no problems with MainType 2.1.1 and above.

What issues do you have?
Erwin Denissen
High-Logic
Proven Font Technology

artbraune
Posts: 45
Joined: Tue Jul 17, 2007 4:33 am

Re: MainType and Windows 7

Postby artbraune » Tue Feb 09, 2010 9:38 pm

I am also having issues with MainType 2.1.1 (build 38) and Windows 7 Professional x64.

MainType will run OK for a bit and then it just goes into "Not Responding". After that - I need to open Task Manager and kill the MainType.exe *32 process and then reopen MainType.

I can provide specific system details if requested.

Hopefully the fact that I have 1882 fonts installed is not the issue...

Thanks much!
Art

Dave Crosby
Typographer
Typographer
Posts: 783
Joined: Mon Feb 23, 2004 1:13 pm
Location: Enoch, Utah

Re: MainType and Windows 7

Postby Dave Crosby » Wed Feb 10, 2010 2:59 pm

artbraune wrote:I am also having issues with MainType 2.1.1 (build 38) and Windows 7 Professional x64.

. . .

Hopefully the fact that I have 1882 fonts installed is not the issue...

Thanks much!
Art


That is a lot of installed fonts that probably will slow down any version of Windows.
I try to keep no more than 100 installed fonts at a time (yeah, it is back over 300 again!) and use the MainType Load feature for special projects.

Not yet forced to 7, hopefully I'm coasting with XP for the next ten years.
Aut nunc aut nunquam

artbraune
Posts: 45
Joined: Tue Jul 17, 2007 4:33 am

Re: MainType and Windows 7

Postby artbraune » Wed Feb 17, 2010 12:37 am

Amazingly Windows 7 is fine with the number of fonts - MainType on the other hand seems to have issues?

thomaus
Posts: 2
Joined: Tue Mar 16, 2010 5:16 pm

Re: MainType and Windows 7

Postby thomaus » Tue Mar 16, 2010 5:25 pm

I'm just having some issues with some fonts in Windows 7.
I migrated a user account from an old XP PC to my new Windows 7 64bit pro PC.
The Microsoft tool to do this didn't move the fonts (like a Mac migration would have), so I manually copied the fonts, and installed them.
My problem is that I get to fonts that were in place on the old PC, and they don't seem to be loaded on the Windows 7 one.
So, I go our central font library, and locate the font files to get them installed.
But Maintype reports:
"Similar font installed but not loaded"
The font doesn't show on the Active list (and I checked to make sure I wasn't filtering out non-loaded font, so I don't think that's it).
This has happened several times, and it's a pain to resolve.
Is there some sort of font cache that's messed up?
Most if not all of the problem fonts were Postscript pfm/pfb fonts.

Erwin Denissen
Moderator
Moderator
Posts: 6567
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: MainType and Windows 7

Postby Erwin Denissen » Wed Mar 17, 2010 8:48 am

MainType 2 on Windows 7 x64 has problems with Type 1 fonts. We expect to release MainType 3 that contains a fix for this within a couple of weeks.
Erwin Denissen
High-Logic
Proven Font Technology

thomaus
Posts: 2
Joined: Tue Mar 16, 2010 5:16 pm

Re: MainType and Windows 7

Postby thomaus » Wed Mar 17, 2010 2:27 pm

Erwin Denissen wrote:MainType 2 on Windows 7 x64 has problems with Type 1 fonts. We expect to release MainType 3 that contains a fix for this within a couple of weeks.


What's odd is that after trying a few things like clicking Uninstall on the server copy of the font, and clicking Load and/or Install - which seemed to have no effect within MainType - the font showed up in InDesign CS4. MainType still doesn't show it in Available; nor does it show up in Control Panel\All Control Panel Items\Fonts directory either.

Instead, InDesign reports that the font is loaded from the server volume where I was trying to install/copy from. But, I've got MainType set to copy to the Fonts directory. So, it's a bit confused.

Is there going to be a beta program on the new version?

Erwin Denissen
Moderator
Moderator
Posts: 6567
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: MainType and Windows 7

Postby Erwin Denissen » Wed Mar 17, 2010 3:27 pm

We are working hard to fix the problem, and we will release one or more private beta's within the next few weeks. I'll keep you informed.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “MainType - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest