opentype glyphs not displayed

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
fcarson
Posts: 3
Joined: Sat Jul 03, 2010 5:00 pm

opentype glyphs not displayed

Postby fcarson » Sat Jul 03, 2010 5:04 pm

I have over 1400 fonts of all types, many of the OTF. I purchased a new OTF font with over 700 glyphs, but MainType only displays 305 of these glyphs....they display correctly inside Adobe Illustrator glyph window...any thoughts on why/how this happens?

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6519
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: opentype glyphs not displayed

Postby Bhikkhu Pesala » Sun Jul 04, 2010 10:47 am

Its not a bug — OpenType glyphs won't be displayed in MainType unless they are mapped to a code-point.

Most OpenType fonts don't map these extra glyphs, though some do, e.g. Myriad Pro or Minion Pro. Try viewing those fonts in MainType — you will find them in the Adobe Reader folder.
My FontsReviews: MainTypeFont CreatorHelpFC10.1 Pro + MT7.0 @ Win10 1703

Erwin Denissen
Moderator
Moderator
Posts: 6309
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: opentype glyphs not displayed

Postby Erwin Denissen » Sun Jul 04, 2010 7:58 pm

The "Show all Glyphs" button located on the toolbar of the Characters pane will do the trick. It is located before the Unicode Block combo box.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “MainType - Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests