Preview and sample show generic text, even when font has all characters

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
nabsltd
Posts: 39
Joined: Tue Oct 18, 2016 12:35 am

Preview and sample show generic text, even when font has all characters

Postby nabsltd » Tue Oct 25, 2016 1:42 am

In MainType 7.0.0, the highlighted font (Mrs Saint Delafield) has all basic latin characters (which you can see from the Characters and Zoom panes), but the preview shows generic:
BadPreview.jpg
BadPreview.jpg (649.47 KiB) Viewed 188 times


When the font is loaded, Word has no problem displaying the font:
MrsSaintDelafield.jpg
MrsSaintDelafield.jpg (101.96 KiB) Viewed 188 times


Although the PANOSE information is wildly incorrect, it is perfectly valid:
MrsSaintDelafieldPANOSE.jpg
MrsSaintDelafieldPANOSE.jpg (79.22 KiB) Viewed 188 times


But, MainType works fine if I set the PANOSE to something more closely resembling the actual font:
MrsSaintDelafield-fixed.jpg
MrsSaintDelafield-fixed.jpg (627.44 KiB) Viewed 188 times

MrsSaintDelafieldPANOSE-fixed.jpg
MrsSaintDelafieldPANOSE-fixed.jpg (84.87 KiB) Viewed 188 times


I don't have the time to completely debug the issue and find exactly what PANOSE changes would be enough to make MainType happy, but suffice to say that it should preview correctly without requiring any changes. The font can be freely downloaded from Google, so it shouldn't be a problem exactly recreating the issue.

Erwin Denissen
Moderator
Moderator
Posts: 6042
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Preview and sample show generic text, even when font has all characters

Postby Erwin Denissen » Tue Oct 25, 2016 1:07 pm

I don't think there is anything wrong with the font. We've recently made some more improvements which will be released with a minor update soon.

In case you don't want to wait; here it is. Do let us know your results.
http://www.high-logic.com/tmp/MainTypeS ... 0.1026.exe
Erwin Denissen
High-Logic
Proven Font Technology

Alfred
Posts: 761
Joined: Thu Apr 18, 2013 8:08 am

Re: Preview and sample show generic text, even when font has all characters

Postby Alfred » Tue Oct 25, 2016 4:30 pm

I've just downloaded the font Mrs Saint Delafield and added it to MainType 7.0 (build 1012, as offered on the download page of this site). The font displays correctly for me, both in the View pane preview and in the Sample pane.
FC10.1 Pro (Help) + MT7.0 (Help) • Windows 10

nabsltd
Posts: 39
Joined: Tue Oct 18, 2016 12:35 am

Re: Preview and sample show generic text, even when font has all characters

Postby nabsltd » Tue Oct 25, 2016 7:10 pm

Erwin Denissen wrote:In case you don't want to wait; here it is. Do let us know your results.
http://www.high-logic.com/tmp/MainTypeS ... 0.1026.exe

It doesn't fix all fonts that had this issue, but it does seem to fix most. It's hard to find these, because the preview is generic serif, but it looks like only about 10 or so fonts are a problem now, when before it was a lot more (mostly Google fonts, as far as more recently created fonts are concerned).

Erwin Denissen
Moderator
Moderator
Posts: 6042
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Preview and sample show generic text, even when font has all characters

Postby Erwin Denissen » Tue Oct 25, 2016 7:33 pm

nabsltd wrote:It doesn't fix all fonts that had this issue, but it does seem to fix most.

That is good news.

Do let us know which ones still cause problems.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “MainType - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest