Wrong character mapping

Get help with Scanahand here. Please do not post feature requests or bug reports here.
Zeboss49
Posts: 8
Joined: Thu Nov 20, 2008 5:06 pm

Wrong character mapping

Postby Zeboss49 » Thu Nov 20, 2008 5:16 pm

Hello,

I have installed Scanahand 2.0 successfully, it runs fine but there is a very bad issue.
The character mapping for the second page is wrong for the characters in the 0x80-0xFF range and for some characters in the 0x100-0x17F range.
The generated font nedd to be manually updated using Font editor.

I currently run Scanahand on a french version of Vista Ultimate.

Both the Microsoft Unicode BMP only and Unicode 2.0 and onwards, BMP are wrong.

This is not a critical issue, it's just boring to have to manually edit the file.
Correcting all the wrong mappings consumes about half an hour.

If this can help I can provide you the original font scratch from Scanahand and the updated one.

Regards

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Thu Nov 20, 2008 5:19 pm

I can't believe this is true, but I've been wrong before...

Please do send them to us, so we can look into the issue. If you don't mind sharing the font, feel free to post them here as well.
Erwin Denissen
High-Logic
Proven Font Technology

Zeboss49
Posts: 8
Joined: Thu Nov 20, 2008 5:06 pm

Re: Wrong character mapping

Postby Zeboss49 » Thu Nov 20, 2008 6:45 pm

Posting the font is OK, but how can I do it ?

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Thu Nov 20, 2008 6:49 pm

While posting, you can click the "Upload attachment" tab right below the text area.
Erwin Denissen
High-Logic
Proven Font Technology

Zeboss49
Posts: 8
Joined: Thu Nov 20, 2008 5:06 pm

Re: Wrong character mapping

Postby Zeboss49 » Thu Nov 20, 2008 7:53 pm

Here after are both font files as attachments
Attachments
LRM Hand Writing Updated.ttf
This is the file with the right mappings, only for MS-Windows, Mac mappings are left unpatched
(29.74 KiB) Downloaded 229 times
LRM hand writing raw.ttf
This is the original file scratch file unpatched
(28.89 KiB) Downloaded 240 times

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Thu Nov 20, 2008 8:10 pm

I do see some strange things, but I don't know if it's due to a bug in Scanahand. To be able to confirm if it's a bug, we also need to have the completed template pages. Could you please upload or send them as well? Could you also let us know what Template you have selected while generating the font in Scanahand?
Erwin Denissen
High-Logic
Proven Font Technology

Zeboss49
Posts: 8
Joined: Thu Nov 20, 2008 5:06 pm

Re: Wrong character mapping

Postby Zeboss49 » Fri Nov 21, 2008 10:37 am

hello,

the font was generated using the Basic and Extended Characters (10x11) 2 pages template.
Here after are the two PNG files used to generate the font
These files have been imported in Scanahand using the "Load" button.
Attachments
LRM Hand Writing Raw P2.png
Filled template page 2 extended character set
LRM Hand Writing Raw P2.png (397.33 KiB) Viewed 7060 times
LRM Hand Writing Raw P1.png
Filled template page 1 basic character set
LRM Hand Writing Raw P1.png (357.25 KiB) Viewed 7058 times

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Fri Nov 21, 2008 11:22 am

Thanks for proving us all requested information. It seems there is an issue with the caption of several of the cells. On the second page of the template you should see these characters in the first row:
À Á Â Ã Ä Å Ą Ç Ć Ĉ
I'll try to see if I can reproduce the problem. Expect a fix of this issue very soon.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Fri Nov 21, 2008 11:32 am

Does page two of the empty template show the same (wrong) captions on screen as when you print them?

And what do you see when you open the Template Editor?
Erwin Denissen
High-Logic
Proven Font Technology

Zeboss49
Posts: 8
Joined: Thu Nov 20, 2008 5:06 pm

Re: Wrong character mapping

Postby Zeboss49 » Fri Nov 21, 2008 11:51 am

The templates have been filled in a vector graphic tool, I have used the export to PDF function to generate the template files.
The preview in Scanahand looks different that the exported PDF files.
It looks like the issue is in the export function
The preview in scanahand displays the right characters.

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Fri Nov 21, 2008 12:21 pm

It would have helped if you provided this information from the start, but we'll get there now that we know the whole story :wink:

There is no native export to PDF feature in Scanahand, so it is safe to say this is not a Scanahand bug. I assume you've produced the PDF by printing the empty template through a PDF producer (for example Acrobat Distiller). If so, then most likely that printer driver is not Unicode aware. Contact the driver vendor and see if they can help. We've had great results with both PDF995 and CutePDF as mentioned here.
Erwin Denissen
High-Logic
Proven Font Technology

Zeboss49
Posts: 8
Joined: Thu Nov 20, 2008 5:06 pm

Re: Wrong character mapping

Postby Zeboss49 » Fri Nov 21, 2008 1:20 pm

Thnak you for your help
the Adobe Acrobat 8 PDF printer driver was guilty.
SInce I have produced the templates I have updated Acrobat to version 9 and with this version the PDF templates are correct.

I apologize for the missing information, I did not remember how I did produce the template files.

Erwin Denissen
Moderator
Moderator
Posts: 6569
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong character mapping

Postby Erwin Denissen » Fri Nov 21, 2008 1:33 pm

Thanks for letting us know. It's good to know the problem was not caused by our software, and I'm glad you've been able to find a solution.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “Scanahand - Support”

Who is online

Users browsing this forum: No registered users and 1 guest