Windows doesn't use bitmaps embedded in .TTF/.OTF

Post questions about type and font design here.
largactyl
Posts: 1
Joined: Fri Sep 11, 2015 3:43 pm

Windows doesn't use bitmaps embedded in .TTF/.OTF

Postby largactyl » Fri Sep 11, 2015 3:49 pm

I'm trying to add embedded bitmaps to my outline (vector) font. It's essentially a 'pixelfont' that is supposed to have a 1:1 "pixel perfect" representation at a size of 12px (which is 9pt, on my 96dpi monitor). My intention is to force that particular size to render as bitmaps (no anti-aliasing); all other sizes would show as outlines.

I used FontForge to generate bitmaps for the 12-pixel size, and embed them into the TrueType/OpenType files. This seems to work correctly - when I reopen the .TTF/.OTF in FontForge, it finds the 12px bitmaps and displays them as intended. However, when the font is installed in Windows, I only see outlines being rendered - even at 9pt (12px), instead of my bitmaps. (I've verified this by modifying a few bitmap glyphs to make the difference apparent.)

I'm using Windows 7 with ClearType enabled. Microsoft says: "ClearType antialiasing is disabled [...] if the font has tuned embedded bitmaps, only for those font sizes that contain the embedded bitmaps." For some reason, this isn't working for me.

Any ideas why I'm not seeing my bitmaps being rendered? Is there some required property that I might be missing, or some way to debug this?

Erwin Denissen
Moderator
Moderator
Posts: 6329
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Windows doesn't use bitmaps embedded in .TTF/.OTF

Postby Erwin Denissen » Fri Sep 25, 2015 7:10 am

I believe the standard EBLC/EBDT embedded bitmaps are only supported with TrueType based fonts.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “Type Design”

Who is online

Users browsing this forum: No registered users and 1 guest