How to enable a glyph, so it can be used as a character?

Before asking a question on FontCreator look here for possible solutions and tutorials. Please do not post support requests here.
Erwin Denissen
Moderator
Moderator
Posts: 6561
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

How to enable a glyph, so it can be used as a character?

Postby Erwin Denissen » Wed Dec 06, 2006 10:56 am

So you have a font that contains one or more glyphs, but you can't use them within your word processor?

Most likely those glyphs are not mapped to a Character, or the mapping is wrong. Here is a font that has two glyphs that won't show up:
Image

Hint: A special border around the colored dot (see the cells with caption Gbreve and gbreve) tells you the Character to Glyph data is missing. It is not always that straightforward, as sometimes a glyph is partially mapped or contains invalid mappings, then you need to dig a little deeper.

Let's find out what is wrong
Select the glyph in the Glyph Overview window and then right click on it and select Properties. Go to the Mappings tab to open the Mappings page as shown here:
Image
Select the Microsoft Unicode BMP only platform (for Symbol fonts select Microsoft Symbol). Now you will see whether there are valid character to glyph index mappings. When the Mappings listbox is empty, no such mapping is available and you need to add one.

Add a character to glyph index mapping
Make sure you have selected the Microsoft platform as mentioned earlier. Then press the Select button. In the top pane select a block to which the glyph belongs but do not press the OK button at this stage. Now in the bottom pane select the character that matches your glyph.
Image

When you can't find the correct Unicode block, visit The Official Unicode Character Code Charts or look at other fonts that do have correct mappings to the specific character. Another way to find it, is to open MainType and select a font that contains the specific character. Then you'll see the Unicode block and the codepoint at once.

When you have successfully added the mapping, you should also consider adding a character to glyph index mapping to the Macintosh platform. However because that platform contains only a few characters, you won't be able to add all mappings. To confirm this, just open another font inside FontCreator and you'll see what can be done here.

Do let me know if this tutorial is useful or if you need more details.
Erwin Denissen
High-Logic
Proven Font Technology

AndreaBari
Posts: 1
Joined: Sun Dec 16, 2007 10:05 am

enable a new glyph created by me

Postby AndreaBari » Sun Dec 16, 2007 10:16 am

Hallo. I would like to ask you a question. I created a glyphs and I added it into a Font that already exist. The question is: How to enable this glyphs in order to show it up? It's not mapped to a Character and thare is no character that matches this glyph becouse that's me that created this glyph. How to do to enable it without matching it with exsisting characters? Thank you very much in advance.
Andrea

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6807
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Postby Bhikkhu Pesala » Sun Dec 16, 2007 12:11 pm

If you can find your glyph in one of the symbol character sets, then you can map it there. If it is a unique symbol the character set to use is the Private use Area.

Use Insert Character (if you have the trial version or Professional version), as this does the mapping and inserts a glyph in one stage. With the Home version, you must insert a glyph, then add mappings as explained above.

This illustration shows how to insert a whole range of ready mapped characters from the Miscellaneous Symbols. Just select a character from the Private Use Area character set instead if that's what you want.
Image

To type these characters in your word-processor you will need to use the insert symbol dialogue, assign a shortcut, or remember its decimal code-point and hold down the Alter key while typing the decimal code-point on the Numbr pad (this method works in WordPad). For example, to type the Fleur-de-lis symbol illustrated, you would hold down Alter and type 9884.

To change the display in dialogues from Hex to Decimal, go to Tools, Options, General, and select Values, Decimal.

See also: this tutorial on the Insert Characters Feature
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703

beaglebuddy
Posts: 2
Joined: Thu Apr 24, 2008 12:10 am
Location: Scottsdale, Arizona, USA

Platforms

Postby beaglebuddy » Thu Apr 24, 2008 3:43 pm

In your post, your "Plaforms" list box shows both "Microsoft Unicode BMP only" as well as "Unicode 1.0 semantics". How did you get these to show up?
Mine only has "Microsoft Symbol".

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6807
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Postby Bhikkhu Pesala » Thu Apr 24, 2008 8:40 pm

See Unicode versus Symbol in the manual. My fonts are all Unicode fonts, yours is a symbol font.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703


Return to “FontCreator - Tutorials and Solutions”

Who is online

Users browsing this forum: No registered users and 1 guest