[CLOSED] Kerning Pairs are lost after saving closing and reopening

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Jonne Haven
Posts: 253
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

[CLOSED] Kerning Pairs are lost after saving closing and reopening

Postby Jonne Haven » Tue Feb 09, 2016 10:40 am

I'm trying my hand at a cursive font, but the kerning has to be precise and can't be autokerned...so I've slaved for 6 months 24/7 working on kerning. Somewhere along the line, kerning values do not get saved as shown in pics below. I can't be manually looking through 7000 kerns everytime I work on this project. I could sure use a hail Mary on this one...because so frustrating to strain my eyes to make a perfect kern only to have it gone the next day. These mishaps do not fall on the same letters but are just more noticeable on some pairs then others.

I thank you for your hard work, please note my other post on winamp in support.

Jonne

The attachment Adjusted perfectly before and other action.jpg is no longer available
Adjusted perfectly before and other action.jpg
Adjusted perfectly before and other action.jpg (335.25 KiB) Viewed 631 times
After saving closing and re-entering.jpg
After saving closing and re-entering.jpg (427.42 KiB) Viewed 631 times

Erwin Denissen
Moderator
Moderator
Posts: 6589
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Kerning Pairs are lost after saving closing and reopening

Postby Erwin Denissen » Tue Feb 09, 2016 11:04 am

I've just:

- Opened the project
- Went to the fr kerning pair and set XAdvance to 140.
- Pressed the OK button.
- Saved the project.
- Opened it again.
- And see the value is 140.

So it works just fine here.
Erwin Denissen
High-Logic
Proven Font Technology

Jonne Haven
Posts: 253
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Re: Kerning Pairs are lost after saving closing and reopening

Postby Jonne Haven » Tue Feb 09, 2016 11:21 am

Sorry to be stubborn on this one but I'm not surprised that if you simply just follow those simple steps there won't be a problem...I do a few kerning with other pairs and other work. I'm trying desperately to find a way to recreate this problem for you to make it apparent that I'm getting sometimes entire letters offline when I come back to the program after saving. So I'll keep trying to duplicate problem.

Thanks for the quick response.

Jonne

Erwin Denissen
Moderator
Moderator
Posts: 6589
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Kerning Pairs are lost after saving closing and reopening

Postby Erwin Denissen » Tue Feb 09, 2016 11:49 am

Also be ware you should no longer change a glyph's side bearings as soon as you start with the kerning. If you do change for example the right side bearing of the "f" all kerning pairs that start with the "f" will have to be corrected.
Erwin Denissen
High-Logic
Proven Font Technology

Jonne Haven
Posts: 253
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Re: Kerning Pairs are lost after saving closing and reopening

Postby Jonne Haven » Tue Feb 09, 2016 11:52 am

Ps - Did you shut down the program in the process you took? That could be an issue. It'smy suspician.

Jonne Haven
Posts: 253
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Re: Kerning Pairs are lost after saving closing and reopening

Postby Jonne Haven » Tue Feb 09, 2016 11:56 am

Good tip, i do that sometimes but not for the project at hand. The cursive kerning can't be changed like that. So you can be sure I don't touch bearings.

Thanks!


Return to “FontCreator - Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests