[PEBKC] OpenType Fractions Not Displaying Correctly

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6815
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

[PEBKC] OpenType Fractions Not Displaying Correctly

Postby Bhikkhu Pesala » Tue Nov 01, 2016 9:19 pm

I haven't changed anything in my scripts AFAIK, but all of my fonts now show this error in FontCreator. In PagePlus, the fraction feature still seems to work as expected.

Typeface Sample published from PagePlus X9.

  1. Standard fractions all work as expected: 1/2 1/3 7/8 etc.
  2. Numeric fractions all work as expected: 11/17 9/5 or whatever
  3. Fractions that use super/subscripted letters are misbehaving.

Fractions.png
Fractions.png (11.03 KiB) Viewed 201 times
Attachments
Acariya Regular.fcp
(284.93 KiB) Downloaded 13 times
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703

Erwin Denissen
Moderator
Moderator
Posts: 6577
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: OpenType Fractions Not Displaying Correctly

Postby Erwin Denissen » Wed Nov 02, 2016 7:32 am

Remember the slash is used to allow for glyph names, so after the slash you can provide a glyph name, which is what you did.

To show the slash, do type it twice.

See also:
viewtopic.php?f=3&t=6107&p=27693&hilit=slash+preview#p27693

Maybe we need to show some kind of warning?
Erwin Denissen
High-Logic
Proven Font Technology

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6815
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: OpenType Fractions Not Displaying Correctly

Postby Bhikkhu Pesala » Wed Nov 02, 2016 8:39 am

Thanks. I had forgotten about that.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703


Return to “FontCreator - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest