Title bar isn't always updated correctly

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
nabsltd
Posts: 40
Joined: Tue Oct 18, 2016 12:35 am

Title bar isn't always updated correctly

Postby nabsltd » Wed Nov 09, 2016 5:26 am

In FontCreator 10.0.0 (build 2125), when you change the font name in the "Font Properties" dialog, the title bar isn't always updated correctly.

This only happens if you click "OK" in the Font Properties dialog when any tab other than "Identification" is active, and only happens the first time you open/close the dialog. Opening the dialog again and clicking "OK" with any tab active will update FontCreator's title bar text.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6341
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Title bar isn't always updated correctly

Postby Bhikkhu Pesala » Thu Nov 10, 2016 10:51 pm

I am not able to reproduce this in later beta builds, so it may be fixed already. .
My FontsReviews: MainTypeFont CreatorHelpFC10.1 Pro + MT7.0 @ Win10

PJMiller
Posts: 270
Joined: Tue Jun 16, 2015 8:12 pm
Location: Sheffield, South Yorkshire
Contact:

Re: Title bar isn't always updated correctly

Postby PJMiller » Fri Nov 11, 2016 7:35 am

I have reproduced this bug in the current version and I remember it from some while ago, it happens intermittently when you change the title, but it isn't a big deal, the title bar gets updated sooner or later and until it does the discrepancy in the title has very little effect on what your'e doing.

I would say it's a very minor inconvenience rather than a bug.

nabsltd
Posts: 40
Joined: Tue Oct 18, 2016 12:35 am

Re: Title bar isn't always updated correctly

Postby nabsltd » Fri Nov 11, 2016 6:51 pm

PJMiller wrote:I have reproduced this bug in the current version and I remember it from some while ago, it happens intermittently when you change the title, but it isn't a big deal, the title bar gets updated sooner or later and until it does the discrepancy in the title has very little effect on what your'e doing.

Since it means I have to open the "Font Properties" window again to make sure that I made the changes I wanted to, and that window often takes 5-10 seconds to populate on my machine (3.5 GHz six-core Ivy Bridge, 64GB RAM, fonts on SSD and TEMP in 16GB RAM disk) when certain tabs (like "Characteristics") were the last one selected, it's a pain in the ass. People with less capable machines have to go get a cup of coffee while that dialog opens.

Better multithreading to deal with background tasks (like gathering the data for that dialog and converting it to the right format and caching it for use in the dialog) would be #1 on my wishlist for FontCreator. It would also allow opening multiple fonts at the same time to keep from locking up both FontCreator and the Explorer window I dragged them from. Or, multi-threading of validation...boy, that would help for fonts with 8000 glyphs.

I would say it's a very minor inconvenience rather than a bug.

Unexpected behavior is a bug, plain and simple.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6341
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Title bar isn't always updated correctly

Postby Bhikkhu Pesala » Fri Nov 11, 2016 7:28 pm

nabsltd wrote:People with less capable machines have to go get a cup of coffee while that dialog opens.

Hyperbole doesn't help your case. It takes 2.5 seconds here on a less-capable machine.

**Specs:** AMD A10-6800K, 8 Gb on Win 7 64-bit

nabsltd wrote:Unexpected behavior is a bug, plain and simple.

In this case you're right, it is a trivial bug unless the name change is not carried over on export, then it would be a significant bug. Note that the font file name, as opposed to the TrueType font name is set in Export Settings. You may want to change that too if you rename a font.

One user expecting something to happen does not make that behaviour a bug if that is how it was programmed to behave.
My FontsReviews: MainTypeFont CreatorHelpFC10.1 Pro + MT7.0 @ Win10

nabsltd
Posts: 40
Joined: Tue Oct 18, 2016 12:35 am

Re: Title bar isn't always updated correctly

Postby nabsltd » Thu Nov 17, 2016 5:50 am

Bhikkhu Pesala wrote:Hyperbole doesn't help your case. It takes 2.5 seconds here on a less-capable machine.

How many font files (and tabs) do you have open? With just one or two, yeah, it's quick. But with 16 fonts and about 30 total glyphs among those fonts open, it takes 6 seconds on my machine if the "PANOSE" tab was the last one opened.

On my laptop (2 cores, 2GB RAM, slow drive), it takes 10-20 seconds if I have more than a couple of tabs open. OK, so I can't go get a cup of coffee in another room, but I do have time to stand up, pour one, and sit back down again.

Erwin Denissen
Moderator
Moderator
Posts: 6060
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Title bar isn't always updated correctly

Postby Erwin Denissen » Thu Nov 17, 2016 1:31 pm

We've noticed it as well. The same software seems to be slower on more recent versions of Windows. I'm afraid it won't be easy to fix, but we'll take a second look at this later.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “FontCreator - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest