[FIXED] Import negative image not working correctly

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
BabelStone
Posts: 28
Joined: Tue Nov 24, 2009 5:08 pm
Contact:

[FIXED] Import negative image not working correctly

Postby BabelStone » Sat Jan 07, 2017 7:47 pm

With latest 10.1 release I just tried importing a negative glyph image. I checked "Negative" and adjusted the threshold until the image was as clear as possible, but when I clicked the generate button the imported image was just a big black rectangle. If I do not check "Negative" then the negative glyph image is imported as expected. In order to import a positive glyph from the negative image I have to set the threshold to 256 minus the threshold value that looks good in the preview (e.g. if negative image looks good at 171, set the threshold to 85), but this looks all black in the preview. Can you test negative glyph import and see if you can reproduce this issue?

Also, with respect to the "Tracing imported bitmaps usually works better with a larger source image, but if you don't have a larger source image, try the Resize option to increase the size of the bitmap used for tracing" message, can you provide a "Do not display this message again" checkbox on the dialog?

PJMiller
Posts: 472
Joined: Tue Jun 16, 2015 8:12 pm
Location: Sheffield, South Yorkshire
Contact:

Re: Import negative image not working correctly

Postby PJMiller » Sun Jan 08, 2017 10:46 am

I also had this but it is easy to work around.

Do not click negative and the image appears in a big black rectangle, delete the rectangle and you are left with the image as a positive but the contours are all the wrong way round so select them all and click the reverse contour button or use the button in the 'Validation' dialog box.

Option two was to invert the image in Irfan View (the application I was copying the image from).

Erwin Denissen
Moderator
Moderator
Posts: 6571
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Import negative image not working correctly

Postby Erwin Denissen » Sun Jan 08, 2017 3:54 pm

Thank you for reporting this issue.

This will be fixed. We will also provide an option to no longer show the warning.
Erwin Denissen
High-Logic
Proven Font Technology


Return to “FontCreator - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest