"Extended" Font Properties not saving

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
jedbadda
Posts: 17
Joined: Wed Jul 13, 2016 9:19 pm

Font/Properties/Extended - Does not save field info!

Postby jedbadda » Sun Feb 19, 2017 10:18 pm

When I enter info into the fields under the 'Extended' tab under Font Properties and click OK, it DOES NOT SAVE THE INFO!

I go back to Font/Properties, click on the 'Extended' tab and the fields are empty. I can't distinguish between fonts in a family like this.

This did not happen with version 10.0 but is happening in version 10.1

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6539
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Font/Properties/Extended - Does not save field info!

Postby Bhikkhu Pesala » Sun Feb 19, 2017 10:33 pm

Help wrote:Typographic Family & Typographic Subfamily (Windows only)

In Windows, the Family name is displayed in the font menu; the Subfamily name is presented as the Style name. For historical reasons, font families have contained a maximum of four styles, but font designers may group more than four fonts to a single family. The Typographic Family and Typographic Subfamily IDs allow font designers to include the preferred family/subfamily groupings. These IDs are only present if they are different from fields Font Family name and Font Subfamily name.

What are you trying to enter? Most information is set on the Identification tab. As the Extended tab says, "Note: In general it's best to leave these naming fields empty."

I have never had a reason to use them, and don't honestly know how I would use them. I have some fonts with more than four sub-families.
My FontsReviews: MainTypeFont CreatorHelpFC10.1 Pro + MT7.0 @ Win10 1703

MikeW
Posts: 355
Joined: Mon May 20, 2013 2:51 pm

Re: Font/Properties/Extended - Does not save field info!

Postby MikeW » Sun Feb 19, 2017 11:10 pm

There are good reasons to enter information on that tab. I too have periods where the information is not saved. Usually a reboot of the computer enables the info to be saved. But not always. Sometimes after a reboot when it doesn't work, exiting and restarting FC makes it work again.

This was never an issue in the early release of version 10 nor in previous versions if I recall.

Erwin Denissen
Moderator
Moderator
Posts: 6329
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Font/Properties/Extended - Does not save field info!

Postby Erwin Denissen » Mon Feb 20, 2017 10:18 am

There is indeed an issue here. For now uncheck "Generate the following naming fields automatically" on the Identification tab.
Erwin Denissen
High-Logic
Proven Font Technology

MikeW
Posts: 355
Joined: Mon May 20, 2013 2:51 pm

Re: Font/Properties/Extended - Does not save field info!

Postby MikeW » Mon Feb 20, 2017 3:52 pm

Thanks for the advice, Erwin.

This has driven me nuts more than once as to the behavior. Glad to know it wasn't me losing what little of my mind I have left!

Mike

nabsltd
Posts: 47
Joined: Tue Oct 18, 2016 12:35 am

"Extended" Font Properties not saving

Postby nabsltd » Thu Mar 09, 2017 5:46 pm

No matter what you enter for "Typographic Family" and "Typographic Subfamily" on the "Extended" tab of the "Font Properties" dialog, it reverts to whatever was there before.

This means that you can't set these for a new project (where they start out blank) and can't change them for an existing project. This also means that any font imported from .TTF or .OTF can't have these values changed. It doesn't appear to be specific to a particular font or file, but I have attached one that definitely fails, just in case.

This may not seem like a big deal, but for me, it's huge, as one of the primary things I do with FontCreator is rename fonts to bring them into a more consistent naming style.
Attachments
Belwe-Regular.otf
(40.11 KiB) Downloaded 4 times

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6539
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: "Extended" Font Properties not saving

Postby Bhikkhu Pesala » Thu Mar 09, 2017 6:59 pm

Please see Erwin's reply to a previous thread, now merged with this one.
My FontsReviews: MainTypeFont CreatorHelpFC10.1 Pro + MT7.0 @ Win10 1703


Return to “FontCreator - Bug Reports”

Who is online

Users browsing this forum: No registered users and 1 guest