Search found 16 matches

by ClintGoss
Wed Jan 31, 2018 5:41 pm
Forum: FontCreator - Support
Topic: Export: Use Current Glyph Names fails (sometimes)
Replies: 2
Views: 372

Re: Export: Use Current Glyph Names fails (sometimes)

I found the problem ... it is not a problem with FontCreator ( sorry !). However, I am leaving this post, in case someone appears to have a similar issue. My problems was that I was examining the exported .TTF file in FontCreator itself. I had never changed the: Options => Generate friendly glyph na...
by ClintGoss
Wed Jan 31, 2018 5:00 pm
Forum: FontCreator - Support
Topic: Export: Use Current Glyph Names fails (sometimes)
Replies: 2
Views: 372

Export: Use Current Glyph Names fails (sometimes)

When I export a .TTF font with the Font Export Settings => TrueType/OpenType => Glyph Names field set to " Use current glyph names ", the exported glyph names are mostly mine, but some have been modified. I can't find a pattern, so I am including the full list... Just looking at glyphs at the beginn...
by ClintGoss
Wed Jan 31, 2018 9:54 am
Forum: FontCreator - Support
Topic: FCP exported TTF font reported as Invalid
Replies: 7
Views: 550

Re: FCP exported TTF font reported a Invalid

Wow ... thanks for the extraordinary speed of response! I have noticed that FontCreator takes any range that I enter for a mapping such as 1F000–​1FFF F and modifies it to 1F000–​1FFF E . However, for a range that ends in FFFF such as F000–​FFFF, the FFFF is not modified to FFFE. Just an observation...
by ClintGoss
Tue Jan 30, 2018 7:13 pm
Forum: FontCreator - Support
Topic: FCP exported TTF font reported as Invalid
Replies: 7
Views: 550

Re: FCP exported TTF font reported a Invalid

Here are the files that demonstrate the problem ...
by ClintGoss
Tue Jan 30, 2018 7:00 pm
Forum: FontCreator - Support
Topic: FCP exported TTF font reported as Invalid
Replies: 7
Views: 550

Re: FCP exported TTF font reported a Invalid

Thank you Erwin ... I will distill the font down a bit to demonstrate the issue more clearly - save you from wading through a pile of glyphs. The Last Resort thing ... it is really an attempt to avoid issues with Microsoft Word, which causes havoc with it's font substitution policy. If the glyph isn...
by ClintGoss
Tue Jan 30, 2018 5:27 pm
Forum: FontCreator - Support
Topic: FCP exported TTF font reported as Invalid
Replies: 7
Views: 550

Re: FCP exported TTF font reported a Invalid

After many tests, I have narrowed down the problem to a font with a glyph mapped to U+FFFF. Here are results from my testing: * A font with a single glyph mapped in the range $0870-$089F, $0B00-$ FFFF fails (i.e. "not a valid font"). * A font with a single glyph mapped in the range $0870-$089F, $0B0...
by ClintGoss
Tue Jan 30, 2018 2:26 pm
Forum: FontCreator - Support
Topic: FCP exported TTF font reported as Invalid
Replies: 7
Views: 550

FCP exported TTF font reported as Invalid

Hi - I export a font from FCP 11.0.0.2412 (64-bit) on Win7x64, and all is fine until ... When I try to install it (from Windows Explorer by R-click Install): "Cannot install XXX.ttf ... The file 'XXX.ttf' does not appear to be a valid font." Windows Font Viewer reports: "The requested file XXX.ttf i...
by ClintGoss
Sat Jan 20, 2018 8:28 pm
Forum: FontCreator - Discussion
Topic: Glyph Names for export
Replies: 2
Views: 448

Re: Glyph Names for export

Thank you!

So, just to confirm, glyphname.dat is used both for the Generate Glyph Names function and for Regenerate for Release on a font export?
by ClintGoss
Sat Jan 20, 2018 3:03 pm
Forum: FontCreator - Discussion
Topic: Glyph Names for export
Replies: 2
Views: 448

Glyph Names for export

In the Font Export Settings dialog box, on the TrueType/OpenType tab, if the " Glyph Names " is set to " Regenerate for release ", are the mappings in the FontCreator file glyphnames.dat used? Or is there some other approach / algorithm that is used on export? I'm thinking that glyphnames.dat might ...
by ClintGoss
Sat Jan 20, 2018 11:53 am
Forum: MainType - Support
Topic: Filter fonts by Code-Point or Block?
Replies: 3
Views: 618

Re: Filter fonts by Code-Point or Block?

Both suggestions are very helpful and this is workable! I can imagine a display - a column in the main font View List - that shows a "Block Coverage" display, maybe color-coded by the % coverage of the block. With 280 blocks, that may be unwieldy ... maybe you get to select which blocks are shown. O...
by ClintGoss
Sat Jan 20, 2018 1:16 am
Forum: MainType - Support
Topic: Filter fonts by Code-Point or Block?
Replies: 3
Views: 618

Filter fonts by Code-Point or Block?

Is there a way in MainType (ver 8.0) to show all or filter fonts that have a given code-point mapped? Or maybe that have code-point in a given block??

-Clint Goss
by ClintGoss
Sun Jan 14, 2018 7:50 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] Bug recognizing non-assigned code points
Replies: 3
Views: 877

Re: Bug recognizing non-assigned code points

Thanks Erwin! This is, of course, a pretty low-priority issue, but one that might cause heartburn here and there for a few folks. I believe that those are the only issues of this type, because with those corrections, the number of total defined Unicode 10.0 code points that are not private use and n...
by ClintGoss
Sun Jan 14, 2018 6:27 pm
Forum: FontCreator - Bug Reports
Topic: [FIXED] Bug recognizing non-assigned code points
Replies: 3
Views: 877

[FIXED] Bug recognizing non-assigned code points

I think this is a bug, although I'm pretty new to this stuff ... I'm using FC Pro 11.0.0.2408, which seems to be the latest, on Win7x64. It appears that a number of the Unicode 10.0.0 blocks have non-assigned characters which are not recognized as such by FCP. In particular (this is cut-pasted from ...
by ClintGoss
Tue Nov 07, 2017 12:31 pm
Forum: FontCreator - Support
Topic: Hiragana / Katakana not recognized
Replies: 8
Views: 562

Re: Hiragana / Katakana not recognized

Thanks for the support, All! I think the real answer is that it's not the fonts, it's my (ill-)chosen App for trying to author a book - Microsoft Word. Yes, there were some issues in my font (thanks to Bhikkhu for taking the time to correct those!) But it is the *breathtakingly arbitrary* way that W...
by ClintGoss
Mon Nov 06, 2017 4:58 pm
Forum: FontCreator - Support
Topic: Hiragana / Katakana not recognized
Replies: 8
Views: 562

Re: Hiragana / Katakana not recognized

Thanks Erwin ... glad to know it wasn't something silly, but sad to know it still unsolved. I have done a trial by setting the checkbox on "JIS/Japan (932)" and turning off Auto Update on export, but no joy. I'm guessing that is what you meant by "manually set specific code page character ranges" .....