Font Previews

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Rob Hodgson
Posts: 2
Joined: Tue Apr 03, 2018 6:27 pm

Font Previews

Post by Rob Hodgson » Wed Apr 04, 2018 4:43 pm

Hi,
I have a problem concerning previews which seems similar to the following...
viewtopic.php?f=12&t=7488
viewtopic.php?f=12&t=7487
viewtopic.php?f=14&t=6736

As I begin to add tags and ratings, some font previews disappear. Their samples and characters either appear in a default font (Arial), don't appear at all, or display the message 'No characters defined'. When I load a font without a preview, the preview appears, but doesn't show samples or characters. The Font Operation window says that the font is 'Not Available', but the font is available in my software, and prints fine.
screengrab_000031an.gif
screengrab_000031an.gif (218.6 KiB) Viewed 67 times
I first encountered this issue in v7 on Win 10 Pro (pre- creators update). My font collection includes various formats (True Type, Postscript, and Open Type) from a variety of sources (bundled with software, purchased online, and downloaded from Font Squirrel etc), but the issue isn't specific to file format, or source. My computer is highly spec'd, so I doubt it's anything to do with memory, rendering or rasterization.

Recently I did a complete clean install of my OS and all software, and upgraded to v8 in the hope that it was solved. I'm now running the latest version of Win 10 Pro. When I install Main Type and point it at my font collection, it scans and shows all my fonts - no problem there. I hoped that a clean install might help, but as I began to add tags and ratings the issue began again.

Any ideas?

Erwin Denissen
Moderator
Moderator
Posts: 7243
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Font Previews

Post by Erwin Denissen » Wed Apr 04, 2018 5:54 pm

I'll need to look into this. I'll contact you.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 7243
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Font Previews

Post by Erwin Denissen » Sat Apr 07, 2018 1:09 pm

I'm not sure how this happened, but it looks like you did delete fonts, which are actually still partly available.

Can you tell me if you did delete fonts, so I might be able to reproduce and solve the problem.
Erwin Denissen
High-Logic
Proven Font Technology

Rob Hodgson
Posts: 2
Joined: Tue Apr 03, 2018 6:27 pm

Re: Font Previews

Post by Rob Hodgson » Mon Apr 09, 2018 11:10 pm

Yeah, I've deleted fonts. I've been slowly restructuring and consolidating my font library, deleting doubles (preferring OT over TT and PS), fonts I'll never use, and older versions, while adding tags. The missing font previews concern font files that haven't been deleted.
Attachments
screengrab_000044.png
screengrab_000044.png (26.13 KiB) Viewed 32 times

Erwin Denissen
Moderator
Moderator
Posts: 7243
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Font Previews

Post by Erwin Denissen » Mon Apr 16, 2018 7:49 am

We've just released an update which solves the issue.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests