Folders & Groups Not Showing in Groups Panel

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Kscearce
Posts: 2
Joined: Tue Sep 14, 2021 5:36 am

Folders & Groups Not Showing in Groups Panel

Post by Kscearce »

I am using MainType latest version (11 xxx build). I installed the software a couple of months ago and in the Groups panel, all my font folders as they're organized on my hard drive showed up. I have more than 12k fonts listed in the software's library,
Library.jpg
Library.jpg (41.43 KiB) Viewed 127 times
My font folders are organized on my hard drive by paid/free and different sources.
All Folders.jpg
All Folders.jpg (135.29 KiB) Viewed 127 times
When I first installed the software, I didn't use the virtual groups feature as my font folders were showing up in the group panel. Earlier today when I opened the software, my folder structure on my hard drive had disappeared from the group panel with the exception of the ones shown here.
ERrors.jpg
ERrors.jpg (45.58 KiB) Viewed 127 times

So I cleared all the font paths, and added them back in, which resulted in ALL of my folders disappearing and as I'd not checked the virtual folder group and wanted to use sync.
No Groups after reinstall.jpg
No Groups after reinstall.jpg (189.23 KiB) Viewed 127 times
So I uninstalled and reinstalled the software. As I'd already tagged a large number of fonts, I kept the library database intact when asked on the reinstall. Since my folders were showing the group panel originally, it didn't occur to me to label bought, paid and from whom when I originally started working with the software. After the reinstall I added in the paths again starting with the root directory F:\ on my NAS. I used the recursively index for the root path I added and checked virtual groups as well. I got nothing. So I then added in a couple of subdirectories from the root. Again nothing.

I've followed the steps in the help section on how to load the folders so they show in the group panel. I've reverted to the default view, but nothing seems to work. I really don't want to have to destroy the database and retag more than 2500 fonts again, but if I do, so be it, but I'm out of ideas on how to fix this to make it work the way it did when I first installed the software and there wasn't a DB. While it could be a bug, it's more than likely I did something to remove the groups to show in totality. TIA Kathi
Erwin Denissen
Moderator
Moderator
Posts: 10075
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Folders & Groups Not Showing in Groups Panel

Post by Erwin Denissen »

For some reason MainType can no longer find fonts within the folders on your F drive.

Can you try to see if it can still detect folders on your C drive?
Erwin Denissen
High-Logic
Proven Font Technology
Kscearce
Posts: 2
Joined: Tue Sep 14, 2021 5:36 am

Re: Folders & Groups Not Showing in Groups Panel

Post by Kscearce »

I copied two font directories into my doc folder (IIRC, I'm not supposed to redirect to the windows fonts directory)

Still nothing. Why do I think I'm going to have to wipe out my db? *sigh*
Attachments
cdrive.jpg
cdrive.jpg (207.97 KiB) Viewed 118 times
Post Reply