Loaded vs Installed

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
smhawk
Posts: 9
Joined: Wed Jun 07, 2006 9:33 pm

Loaded vs Installed

Post by smhawk » Thu Jan 29, 2009 12:41 am

Even though I have been using MainType for some time now, I'm still not clear about the difference between "Loaded" and "Installed." Can someone provide a clear and simple explanation?

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8446
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Loaded vs Installed

Post by Bhikkhu Pesala » Thu Jan 29, 2009 6:48 am

Fonts that are loaded will only remain available in Windows applications until you reboot your PC.

Fonts that are installed will be available the next time you start your PC.

Loading fonts is therefore useful for a special print job using fonts that are not often used.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1909 build 18363.592

smhawk
Posts: 9
Joined: Wed Jun 07, 2006 9:33 pm

Re: Loaded vs Installed

Post by smhawk » Thu Jan 29, 2009 7:03 am

Bhikkhu Pesala wrote:Fonts that are loaded will only remain available in Windows applications until you reboot your PC.

Fonts that are installed will be available the next time you start your PC.

Loading fonts is therefore useful for a special print job using fonts that are not often used.
Bhikkhu, thanks for the quick response. Yes, so far so good. But, when I reboot, "loaded" fonts are still listed as loaded, and "installed" fonts are listed as installed. What's the practical difference? Caveat: I'm using a 64-bit version of Vista, and, frankly, I can't remember if MainType worked the same way on my old 32-bit XP system.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8446
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Loaded vs Installed

Post by Bhikkhu Pesala » Thu Jan 29, 2009 9:12 am

See also this thread.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1909 build 18363.592

Erwin Denissen
Moderator
Moderator
Posts: 8385
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Loaded vs Installed

Post by Erwin Denissen » Thu Jan 29, 2009 10:14 am

After a reboot, all fonts loaded in an earlier Windows session have to be loaded again. They can't be automatically become loaded, if your want a font to be permanently loaded, you have to install it.
smhawk wrote:But, when I reboot, "loaded" fonts are still listed as loaded, and "installed" fonts are listed as installed.
If you see loaded fonts after a reboot, then another application has been started and has loaded these fonts. Windows also loads several vector and/or raster fonts. Please let us know which fonts are loaded, so we might be able to tell you which third party software loads them.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 8385
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Loaded vs Installed

Post by Erwin Denissen » Fri Jan 30, 2009 1:56 pm

smhawk send me an email yesterday. It included some screenshots; I've uploaded the most relevant one here as well:
smhawk wrote:Greetings, Erwin. Since you've joined the loaded vs installed thread on the forum, here are a couple of screenshots for you. After rebooting, I immediately started MainType and sorted by font status. These and many more fonts are still loaded (these loaded fonts are available in InDesign CS4, by the way). Also, before rebooting, I installed a font named Lydian (name doesn't reeally matter) from a CD. It appeared in MainType, but not in windows/fonts. After rebooting, it disappeared from MainType.
maintype64smhawk.gif
maintype64smhawk.gif (134.28 KiB) Viewed 7497 times
I suspect this behavior is related to the problem (and solution) mentioned here:
Re: postscript fonts no longer accessible in MT

If true, then the problem not only occurs on Windows XP but also on Windows Vista x64 Edition. Let us know your results!
Erwin Denissen
High-Logic
Proven Font Technology

smhawk
Posts: 9
Joined: Wed Jun 07, 2006 9:33 pm

Re: Loaded vs Installed

Post by smhawk » Fri Jan 30, 2009 9:16 pm

Erwin Denissen wrote:
I suspect this behavior is related to the problem (and solution) mentioned here:
Re: postscript fonts no longer accessible in MT

If true, then the problem not only occurs on Windows XP but also on Windows Vista x64 Edition. Let us know your results!
No luck. The registry fix did not solve the problem. The fonts all appear as "loaded" on reboot.

opeter
Posts: 34
Joined: Thu Dec 11, 2008 1:02 pm
Location: Lendava, Slovenia (EU)

Re: Loaded vs Installed

Post by opeter » Wed Feb 04, 2009 9:25 am

And if you try, to "uninstall" these fonts?

smhawk
Posts: 9
Joined: Wed Jun 07, 2006 9:33 pm

Re: Loaded vs Installed

Post by smhawk » Wed Feb 04, 2009 5:30 pm

opeter wrote:And if you try, to "uninstall" these fonts?
Failure.

Uninstall: Failed to uninstall the font
Unload: Failed to unload because the font file is unknown.

72dpi
Posts: 5
Joined: Sat Sep 25, 2010 2:20 pm

Re: Loaded vs Installed

Post by 72dpi » Wed Apr 06, 2011 7:26 pm

What happened here guys, you all just gave up on the matter?

I have the exact same problem, and have had it multiple times. This is my main problem with MainType. Any solution to the problem?

Erwin Denissen
Moderator
Moderator
Posts: 8385
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Loaded vs Installed

Post by Erwin Denissen » Thu Apr 07, 2011 9:15 am

Please provide some more detailed information, and we will look into this.

What O.S. are you running?
What version of MainType?
What fonts have a problem?
What is the problem?

Did the problem first occur after a specific update, reinstall, etc?
Erwin Denissen
High-Logic
Proven Font Technology

72dpi
Posts: 5
Joined: Sat Sep 25, 2010 2:20 pm

Re: Loaded vs Installed

Post by 72dpi » Thu Apr 07, 2011 2:12 pm

I'm running Windows 7, MainType 3.0 build 128.

There's two types of fonts.

1. Sometimes regular fonts get stuck in a loaded state. When you try to locate them (Open Containing Folder), there's no location. I think it might have something to do with deleting the font files before uninstalling the fonts in MainType. In these cases it seems to get fixed after restarting the computer. However, I don't see why there shouldn't be an option to flush the fonts from MainTypes cache.

2. There's always some permanent "stuck" fonts. Right now MainType lists Adobe Fangsong Std R, Adobe Heiti Std, Kozuka Mincho Pr6N (among others) as loaded fonts. When trying to locate them I don't get any location (an explorer window opens where the path is just my desktop). When trying to uninstall them I get "Failed to uninstall font". I can't remember ever installing these, so they might be some kind of system fonts or something.

Since MainType is listing the fonts, i presume MainType knows where it got them from (unless the fonts magically appears in MainType). Why not just give users the option to "flush the cache" or "delete font registry entry" or whatever needed to get rid of it?

Post Reply