Unable to get rid of "active" fonts

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Hoods
Posts: 3
Joined: Mon Dec 10, 2012 8:50 am

Unable to get rid of "active" fonts

Post by Hoods » Wed Dec 19, 2012 11:58 am

Hi Erwin

Related to this old problem but I didn't see a solution

viewtopic.php?f=13&t=3975&p=17378&hilit ... all#p17378

I have two fonts (families) which I can't get rid of from the Active area, no matter what I do - there is no option to remove/delete the fonts. I have done a FULL uninstall - removing all databases etc - using even Revo Pro then reinstalling. I know the fonts are fine (Basic Sans and Register) because I always use them. Now, even when I try to reinstall the fonts Main Type says I am installing the font, but it just adds another instance with a red dot. I did something wrong - I forget what - for the fonts to have have gained the red dot for an "unknown font".

Incidentally, I have a few other font programs, some very basic ones don't show the fonts as installed. I have Printer's Apprentice, which also shows these fonts in the Active folder and "unknown" and I likewise have no option to delete them.

Any suggestion? Something I can delete in the registry??

Any help will be appreciated as these are two of my favourite fonts!

Regards
Robin

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8407
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Unable to get rid of "active" fonts

Post by Bhikkhu Pesala » Mon Dec 24, 2012 7:40 pm

I just ran into this problem. Rebooting didn't solve the problem, so I uninstalled MainType, removed my databases, and reinstalled it. It didn't take long to rebuild my font library. I have 3,120 fonts in my library.

All is well again now.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

Erwin Denissen
Moderator
Moderator
Posts: 8319
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Unable to get rid of "active" fonts

Post by Erwin Denissen » Mon Dec 24, 2012 9:38 pm

If the problem persists after a full uninstall, it might be a bug.

I'll contact you next week (next year), to look for a solution.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 8319
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Unable to get rid of "active" fonts

Post by Erwin Denissen » Fri Jan 11, 2013 8:57 am

Robin, I'm glad you told us you did solve the issue by rebooting.

A little background information might help other uses as well:

The fonts you tried to remove were fonts unknown by MainType (e.g. fonts with red "unknown fonts" dots). You will see such fonts when other software load fonts without providing information about the exact location of the fonts. Then there is no way of retrieving additional information about the fonts, and it is not possible to uninstall/unload/deactivate such fonts.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply