h/l upgrade 5 to 6 ,vault not finding older vault entries

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
cliff
Posts: 5
Joined: Sun Nov 15, 2015 11:35 am

h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by cliff » Sun Nov 15, 2015 11:44 am

updated to h/l 6 and the vault not adding older entries into the library it just finds my installed active fonts, the older vault files are listed as vlt.oo1,oo2 etc there are about 15,000 fonts I don't want to lose. any help on this matter would be appreciated

Erwin Denissen
Moderator
Moderator
Posts: 6899
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by Erwin Denissen » Sun Nov 15, 2015 9:47 pm

Is MainType 6 using another/new version of your database files?

You can see which ones it is using by starting the FmsConfig utility. You can access it from Windows Start menu -> All Programs -> High-Logic MainType -> High-Logic FmsConfig. Or in case you are running Windows 8, Windows 8.1 or Window 10, do search for FmsConfig. Do let us know your findings!
Erwin Denissen
High-Logic
Proven Font Technology

cliff
Posts: 5
Joined: Sun Nov 15, 2015 11:35 am

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by cliff » Sun Nov 15, 2015 10:53 pm

is this what you wanted

[ High-Logic Font management service ]
File location : C:\Program Files (x86)\High-Logic FontService\fontservice.exe
Version : 3.1.0.850

[ High-Logic MainType ]
File location : C:\Program Files (x86)\High-Logic MainType\maintype.exe
Version : 6.0.0.958

[ High-Logic Proxy ]
File location : C:\Program Files (x86)\High-Logic MainType\FmsProxy.exe
Version : 1.2.0.189

[ High-Logic Font management service configuration utility ]
File location : C:\Program Files (x86)\High-Logic FontService\FmsConfig.exe
Version : 1.3.0.144

[ High-Logic Font management service support library ]
File location : C:\Program Files (x86)\High-Logic FontService\sqlite3.dll
Version : 3.8.5.0

[ High-Logic FontService Library ]
File location : C:\WINDOWS\system32\hlfontlib.dll
Version : 2.2.0.334

Erwin Denissen
Moderator
Moderator
Posts: 6899
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by Erwin Denissen » Mon Nov 16, 2015 8:27 am

That looks just fine.

Can you show a screenshot of MainType? That might reveal more.
Erwin Denissen
High-Logic
Proven Font Technology

cliff
Posts: 5
Joined: Sun Nov 15, 2015 11:35 am

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by cliff » Mon Nov 16, 2015 9:41 am

heres a screenshot
MainType6.jpg
MainType6.jpg (191.01 KiB) Viewed 1003 times

Erwin Denissen
Moderator
Moderator
Posts: 6899
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by Erwin Denissen » Mon Nov 16, 2015 9:52 am

When you have MainType 5 running on your system, and then install version 6, it should automatically upgrade your existing font data.

Obviously this didn't work on your system, so I wonder why. Did you uninstall version 5 before installing version 6?

The database and other data are located at C:\ProgramData\High-Logic FontService
MainTypeData.png
MainTypeData.png (98.25 KiB) Viewed 1003 times
Erwin Denissen
High-Logic
Proven Font Technology

cliff
Posts: 5
Joined: Sun Nov 15, 2015 11:35 am

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by cliff » Mon Nov 16, 2015 10:05 am

no I had 5 installed

the file locations shown

cache 0
data 0
and
vault 13/2/2013 vlt 18kb

cliff
Posts: 5
Joined: Sun Nov 15, 2015 11:35 am

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by cliff » Tue Nov 17, 2015 7:43 am

problem sorted when I upgraded to windows 10 for some reason the cache and data etc where created on another drive I was going through one off my backup drives and noticed a font service file on it I just copied to my system folders and all good, i forgot how many fonts I had 40,000+ thanks for your time and effort

Erwin Denissen
Moderator
Moderator
Posts: 6899
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: h/l upgrade 5 to 6 ,vault not finding older vault entries

Post by Erwin Denissen » Tue Nov 17, 2015 7:51 am

I'm glad the problem is solved. Enjoy the software (and your fonts).
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests