Where did my font go?

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Alfred
Top Typographer
Top Typographer
Posts: 916
Joined: Thu Apr 18, 2013 8:08 am

Where did my font go?

Post by Alfred » Wed Sep 14, 2016 12:23 pm

In the 'Add Font Folder' dialog in MainType 7.0, I browsed to a folder containing 404 fonts and put a tick in the 'Create groups after indexing' checkbox. When I pressed the 'OK' button, 403 fonts were added to a new group. There was nothing noted in the errors ('Invalid Font Resources') dialog.

How do I find out which font was not added, and preferably also the reason for this omission?
FC11.0 Pro (Help) + MT7.0 (Help) • Windows 10

Erwin Denissen
Moderator
Moderator
Posts: 6849
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Where did my font go?

Post by Erwin Denissen » Wed Sep 14, 2016 12:31 pm

I suspect the folder contains two identical font files, so MainType only shows one.

You can browse through all the fonts in MainType, and look at the resources in the Font Information panel. One of them should display two different resource files.
Erwin Denissen
High-Logic
Proven Font Technology

Alfred
Top Typographer
Top Typographer
Posts: 916
Joined: Thu Apr 18, 2013 8:08 am

Re: Where did my font go?

Post by Alfred » Wed Sep 14, 2016 6:58 pm

Almost half of the fonts were already installed, so for those fonts the Font Information panel displays two different resource files (one in the Windows Fonts folder, and the other in the folder which I added) but that doesn't help me identify the one font out of 404 which wasn't added to the new group. :(
FC11.0 Pro (Help) + MT7.0 (Help) • Windows 10

Erwin Denissen
Moderator
Moderator
Posts: 6849
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Where did my font go?

Post by Erwin Denissen » Tue Oct 25, 2016 12:33 pm

Maybe the folder contains 403 fonts and an image or text file?
Erwin Denissen
High-Logic
Proven Font Technology

Alfred
Top Typographer
Top Typographer
Posts: 916
Joined: Thu Apr 18, 2013 8:08 am

Re: Where did my font go?

Post by Alfred » Tue Oct 25, 2016 3:45 pm

Erwin Denissen wrote:Maybe the folder contains 403 fonts and an image or text file?
That's the answer, Erwin! It hadn't occurred to me that there might have been anything other than font files in the folder, so I didn't try sorting the list by type instead of filename. :oops:

Included in the folder is a *.lst file, which is a directory listing only 103 files (102 TTF files plus the LST file itself). Not very useful, given that more than 300 TTF files were subsequently added to the collection. :roll:
FC11.0 Pro (Help) + MT7.0 (Help) • Windows 10

Erwin Denissen
Moderator
Moderator
Posts: 6849
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Where did my font go?

Post by Erwin Denissen » Tue Oct 25, 2016 3:49 pm

I'm glad to know it isn't an issue with MainType :lol:
Erwin Denissen
High-Logic
Proven Font Technology

Alfred
Top Typographer
Top Typographer
Posts: 916
Joined: Thu Apr 18, 2013 8:08 am

Re: Where did my font go?

Post by Alfred » Tue Oct 25, 2016 3:52 pm

Me too, although I should have known better than to think it might have been! ;)

Thanks for solving the mystery. :)
FC11.0 Pro (Help) + MT7.0 (Help) • Windows 10

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest