After upgrade from MainType 7 to 8, some fonts have no preview

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
Enigma
Posts: 50
Joined: Thu Apr 08, 2010 11:23 pm
Location: Kiel, Germany

After upgrade from MainType 7 to 8, some fonts have no preview

Post by Enigma » Fri Jan 19, 2018 8:56 am

Hello,

today I upgraded from MainType 7 Professional Edition to version 8 (same edition). After refreshing all font folders manually, all fonts showed up, so I don't think my problem is the same as described in Fonts not showing after upgrading from v7 to v8.

On my Windows 10 system, 1668 of my 18058 fonts are installed. Most fonts do have a preview, but unfortunately quite a few don't have one, the field is empty there. In the Characters panel, all cells are empty, too, and the Sample panel uses a system font. Font information, ratings, and tags are correct, though.

As it seems, by far most of the fonts without preview are active ones, but there are a few inactive ones without preview, too. Also, there are many active fonts with preview. In font families, either all fonts do or don't have a preview, I didn't find families with "mixed display".

I'm using groups, tags and ratings extensively, so I wouldn't want to remove and re-import the fonts, if possible.

It would be great if we could resolve this issue. Thank you very much in advance for your help!

Cheers,
Jan
You have moved the mouse. Windows must be restarted for the changes to take effect.

Erwin Denissen
Moderator
Moderator
Posts: 7320
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: After upgrade from MainType 7 to 8, some fonts have no preview

Post by Erwin Denissen » Fri Jan 19, 2018 9:30 am

I'm sorry about the inconvenience, but I'm sure we can fix it.

I've contacted you.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 7320
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: After upgrade from MainType 7 to 8, some fonts have no preview

Post by Erwin Denissen » Fri Jan 19, 2018 4:12 pm

We've just release a maintenance update, which should solve this issue. Either re-download MainType from our website and install it, or use the Update feature within MainType.

Let us know your results!
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 7320
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: After upgrade from MainType 7 to 8, some fonts have no preview

Post by Erwin Denissen » Sat Jan 20, 2018 1:31 pm

This issue is most likely due to a Windows update bug that affects some but not all computers.

Another user also had this very same issue and was able to solve it by following the steps we provided here:
Fonts need to be unloaded/loaded in order to work; Indesign autoload not working

Let us know if this solves it for you as well.
Erwin Denissen
High-Logic
Proven Font Technology

Enigma
Posts: 50
Joined: Thu Apr 08, 2010 11:23 pm
Location: Kiel, Germany

Re: After upgrade from MainType 7 to 8, some fonts have no preview

Post by Enigma » Sat Jan 20, 2018 2:39 pm

Erwin was so kind to take a look for himself via TeamViewer. As it turned out, the problem obviously just coincidentally occurred directly after upgrading to MainType 8. The procedure described in the thread he just linked to worked fine, all fonts are displayed as they should now.

As mentioned in the other thread, this seems to be a Windows bug and is not associated with MainType. I suddenly had problems in Illustrator and Word that I hadn't even noticed yet...

I had an issue with a single font when I reinstalled the uninstalled fonts - there was an error message saying that a similar font was already installed, and I couldn't access it via MainType -, but I could solve it by dragging the file to the Windows font folder manually. I was asked if I wanted to replace the font, which I accepted. After the next reboot everything was fine again.

Thank you, Erwin, for your great support! :)

Cheers,
Jan
You have moved the mouse. Windows must be restarted for the changes to take effect.

sjsissjs
Posts: 49
Joined: Fri Apr 07, 2006 8:07 pm

Re: After upgrade from MainType 7 to 8, some fonts have no preview

Post by sjsissjs » Sun Jan 28, 2018 10:12 pm

Hello Erwin,

I just downloaded MainType 8.0, 8.0.0.1127, 64 bit, Windows 10 (fully up to date, I think) and experienced the same missing preview of certain fonts. Switching to list view shows all the fonts. I did uninstall and reinstall the missing fonts and all are now showing a preview. I had about 30 so not too terrible; it would be a hassle if there were hundreds.

Curiously, all were Adobe OTF fonts and were in an Adobe folder, not in the Windows Fonts Folder. All showed that they were installed in Windows Explorer. Once uninstalled and reinstalled, they also showed up in the Fonts folder.

Otherwise all looks good. Thanks for your work on this.

Steve
____

Enigma
Posts: 50
Joined: Thu Apr 08, 2010 11:23 pm
Location: Kiel, Germany

Re: After upgrade from MainType 7 to 8, some fonts have no preview

Post by Enigma » Mon Jan 29, 2018 6:40 am

sjsissjs wrote:
Sun Jan 28, 2018 10:12 pm
Curiously, all were Adobe OTF fonts and were in an Adobe folder, not in the Windows Fonts Folder.
That was different in my case; fonts from several sources were affected. What was conspicious was the fact that only complete font families were affected.

Cheers
Jan
You have moved the mouse. Windows must be restarted for the changes to take effect.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests