need to restart application everytime

Get help with MainType here. Please do not post feature requests or bug reports here.
Post Reply
lousmith
Posts: 4
Joined: Sun Apr 29, 2018 4:47 pm

need to restart application everytime

Post by lousmith » Wed Jun 27, 2018 1:29 pm

Hi,
I have been using MainType successfully for a while now, but recently when I install a font from MainType, it is not available anymore in whatever application I have already open. I need to close the application and re-open it again for the font to be available. Until last week, the font was immediately available with no need to restart various applications.
Does anyone know how to fix this?

Thanks!

Lou

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8521
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: need to restart application everytime

Post by Bhikkhu Pesala » Wed Jun 27, 2018 3:10 pm

No such problem here. Fonts appear/disappear from my application's font menu when I instal/uninstall. Tested with Serif PagePlus X9 on Windows 10 latest update.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1909 build 18363.720

lousmith
Posts: 4
Joined: Sun Apr 29, 2018 4:47 pm

Re: need to restart application everytime

Post by lousmith » Wed Jun 27, 2018 4:40 pm

I am very happy it's working great for you, but any ideas how I can get it working again for me?!
I use Windows 10. I need to restart MS Excel and Paint.net (and probably more applications) to get a newly installed font to show up. But MS Word picks it up without the need to restart.
Those same applications were picking up the newly installed fonts just fine previously.
Do I need to reinstall MainType? Any other suggestions?
Thanks!

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8521
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: need to restart application everytime

Post by Bhikkhu Pesala » Wed Jun 27, 2018 5:30 pm

If it's working with Word, but not with other apps, I doubt if reinstalling MainType will fix anything.

It may be due to a recent Windows update.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1909 build 18363.720

Alfred
Top Typographer
Top Typographer
Posts: 1028
Joined: Thu Apr 18, 2013 8:08 am

Re: need to restart application everytime

Post by Alfred » Wed Jun 27, 2018 5:47 pm

Bhikkhu Pesala wrote:
Wed Jun 27, 2018 3:10 pm
No such problem here. Fonts appear/disappear from my application's font menu when I instal/uninstall. Tested with Serif PagePlus X9 on Windows 10 latest update.
I have never seen newly installed fonts in PagePlus (or any other ‘Plus’ application) until the next time I launch it. Serif’s Affinity apps update the font cache when a font is loaded or unloaded, but even then I have to close and reopen any affected document (although not the app itself) to see the effect of the change.
FC11.5 Pro (Help) + MT8.0 Pro (Help) • Windows 10

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8521
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: need to restart application everytime

Post by Bhikkhu Pesala » Wed Jun 27, 2018 6:25 pm

Alfred wrote:
Wed Jun 27, 2018 5:47 pm
I have never seen newly installed fonts in PagePlus (or any other ‘Plus’ application) until the next time I launch it.
Which version of MainType are you using? Not that it should matter. Auto-update of the font list has worked for many years.
Aachan Bold Not Installed.png
Aachan Bold Not Installed.png (18.42 KiB) Viewed 1523 times
Aachan Bold Added.png
Aachan Bold Added.png (18.84 KiB) Viewed 1523 times
Aachan Bold Uninstalled.png
Aachan Bold Uninstalled.png (18.43 KiB) Viewed 1523 times
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1909 build 18363.720

Alfred
Top Typographer
Top Typographer
Posts: 1028
Joined: Thu Apr 18, 2013 8:08 am

Re: need to restart application everytime

Post by Alfred » Wed Jun 27, 2018 7:06 pm

Bhikkhu Pesala wrote:
Wed Jun 27, 2018 6:25 pm
Which version of MainType are you using? Not that it should matter. Auto-update of the font list has worked for many years.
My apologies. I allowed myself to get confused between the behaviour due to MainType and the behaviour due to PagePlus! If I install a new font via Windows Font Viewer, PagePlus doesn’t ‘see’ the font until the next time I launch it (but the font is immediately available for use in Affinity Designer even if it’s already running).

The thing is, if I’m only installing one or two fonts it isn’t worthwhile launching MainType instead of simply opening each file in Windows Font Viewer and pressing the ‘Install’ button, and if I’m installing the contents of an entire folder I’ll do it from MainType with my graphics apps closed, so I never normally see the effects of MainType doing its clever stuff in the background.
FC11.5 Pro (Help) + MT8.0 Pro (Help) • Windows 10

Post Reply