Font not loading - similar name conflict

Got a request? Post it here. Please do not post bug reports here.
Post Reply
catamountain
Posts: 4
Joined: Sun Mar 25, 2007 10:28 pm

Font not loading - similar name conflict

Post by catamountain » Sun Mar 25, 2007 10:52 pm

I recently tried to load a symbol font called 'Zymbols'. I got an error message saying a font with a similar name was loaded. The only other with a similar name was 'Symbols'.

I was able to manually place the Zymbols TTF file in the Windows font directory without a problem.

Maybe Maintype should be a little less sensitive. Other than that, I am very happy with the program.

On a positive note, by coming to this forum about this issue I read about fontrenamer programs. Those sounds like nice, useful utilities.

Erwin Denissen
Moderator
Moderator
Posts: 8195
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Mon Mar 26, 2007 5:15 am

Good to know the forum is useful to you.

The Zymbols issue sounds interesting. Can you send the font file to me, so I can investigate the problem?
Erwin Denissen
High-Logic
Proven Font Technology

catamountain
Posts: 4
Joined: Sun Mar 25, 2007 10:28 pm

Post by catamountain » Tue Mar 27, 2007 2:10 am


Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8253
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Post by Bhikkhu Pesala » Tue Mar 27, 2007 5:28 am

Corrected Link

I had no problems installing the font.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT8.0 @ Win10 1809 build 17763.557

Erwin Denissen
Moderator
Moderator
Posts: 8195
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Tue Mar 27, 2007 5:40 am

I'm sure MainType makes a distinction between Symbols and Zymbols, so that can't be the problem.

I think I now understand what's happening. You must have already loaded the Zymbols font, MainType ensures you are not loading the same font more than once, since Windows can only handle one. You might not be aware of this, but when you double-click a font file, by default it opens in Windows font viewer. In order to show a preview of your font, it has to load the font. Maybe that's what happened. The solution is very easy, just close Windows font viewer.

Maybe the status message "A similar font is already installed/ loaded." in MainType should be more informative, or should link to a topic in the help file.
Last edited by Erwin Denissen on Tue Mar 27, 2007 3:08 pm, edited 1 time in total.
Erwin Denissen
High-Logic
Proven Font Technology

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8253
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Post by Bhikkhu Pesala » Tue Mar 27, 2007 7:27 am

I found that having the Windows Font Viewer open with the font that I was installing made no difference. (Windows XP Home)

You could enable the Option to Smart Install/Load fonts. This will uninstall/unload fonts automatically if they are already installed/loaded. The uninstalled fonts are saved in a backup folder.

I don't think MainType is too sensitive, but if you wish you can turn off warnings in Options.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT8.0 @ Win10 1809 build 17763.557

catamountain
Posts: 4
Joined: Sun Mar 25, 2007 10:28 pm

Post by catamountain » Thu Mar 29, 2007 12:52 am

I had the Windows font viewer open and got my error message while Loading. Then I closed the font viewer and tried to Load again and got the same error message. Then I closed MainType and reopened the program and tried again. Same error. Then I tried to uninstall the font. But nothing seemed to happen.

Finally I open the Windows Font directory and looked at the installed files and could not see an obvious name conflict. So I copied the Zymbols font there and got the one character in that file I wanted to use. It's not an important font I want to install -

I will look into the Option to Smart Install/Load font and exploring my options in Options. This is a great opportunity to earn a better command of this fine program. Thanks for the advice.

Erwin Denissen
Moderator
Moderator
Posts: 8195
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Thu Mar 29, 2007 5:52 am

Hi catamountain,

Most likely you already started using the font (within Word, CharMap or another application) while you had the font opened in Windows font viewer. In this case closing the font viewer will not unload the font, since it is in use. Closing all software or even a reboot usually solves this issue.
Erwin Denissen
High-Logic
Proven Font Technology

catamountain
Posts: 4
Joined: Sun Mar 25, 2007 10:28 pm

Post by catamountain » Sat Mar 31, 2007 7:36 pm

Hi Erwin Denissen

I think that is it. I either did not close enough software or the reboot fix it. I was hunting through recently downloaded symbol fonts for one character I remembered. One instance of Windows font viewer was opened then closed, but I mainly relied on MainType to scan though the files.

Today I was able to Load the offending font via MainType. This is the second time this week I underestimated the cleansing power of rebooting.

Thanks

Post Reply