Won't add fonts to library if ANY are "corrupt"

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Post Reply
mshubes
Posts: 19
Joined: Thu Jun 18, 2020 2:01 pm

Won't add fonts to library if ANY are "corrupt"

Post by mshubes »

While adding fonts to my library, one of the folders had a 0 fonts added to the library. But there were over 200 fonts in that folder. There were no error messages while adding the fonts to the library. Rather, MainType appeared to have added all fonts successfully.

I verified the font count on all the other folders, then tried to discover why one folder had ZERO fonts.

I divided the fonts in that folder into subfolders and added each separately. When one folder had 0 fonts added, I would break it down further into subfolders, thus narrowing down the location of the "bad" font.

I found it.

Shouldn't the software add all the "good" fonts and show errors for those it cannot add (and WHY it cannot add them, if possible)? If I had not noticed the font count was off so badly, I would not have known there was a problem.

P.S. The problem font was a Google font named "Play." It does not appear to be corrupt as Windows Font Viewer displays it just fine. (If you want to test why MainType will not allow it to be added to the library: https://fonts.google.com/specimen/Play?query=play)
Erwin Denissen
Moderator
Moderator
Posts: 10489
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Won't add fonts to library if ANY are "corrupt"

Post by Erwin Denissen »

Thank you for reporting this issue; much appreciated!

We will look into this and hope to find a solution soon.
Erwin Denissen
High-Logic
Proven Font Technology
Erwin Denissen
Moderator
Moderator
Posts: 10489
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Won't add fonts to library if ANY are "corrupt"

Post by Erwin Denissen »

This is due to a bug in our software, the fonts are fine. We will soon release an update that should solve this issue.
Erwin Denissen
High-Logic
Proven Font Technology
Erwin Denissen
Moderator
Moderator
Posts: 10489
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Won't add fonts to library if ANY are "corrupt"

Post by Erwin Denissen »

This update should fix the issue:

MainType 11.0.0.1274 (64-bit)

Let us know your results.
Erwin Denissen
High-Logic
Proven Font Technology
Post Reply