CS4 Problem with PostScript 1-Fonts

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
resign.ch
Posts: 1
Joined: Sat Jan 31, 2009 11:56 am

CS4 Problem with PostScript 1-Fonts

Post by resign.ch » Sat Jan 31, 2009 12:44 pm

Hello

I use Post-Script Type 1 Fonts from the Adobe Font Folio.
I install and/or loaded the fonts with MainType 2.1.1 und it works great on all CS3 Programms (Photoshop, InDesign, Illustrator, Flash...) until now.

But now i install the new CS4 Collection on my system (cs3 is allready installed).
All cs4-Programms dont Display the PostScript-Fonts in de Text-Menu... this error comes only in CS4 (photoshop, indesign, flash, etc.) MainType says, Font is installed and loaded.... i work on VISTA Home Premium 64-bit.

Is this Problem a knowed error?
does CS4 a other way to handle PS_Fonts den ins cs3?

please let me know, i can work at the moment on cs4, because of the missing PS-Fonts :(
(all openType or TrueType-Fonts doing well)

Thans for your Feedback an sorry for my bad swiss-english :)

greetings from Zurich
RESIGN

opeter
Posts: 34
Joined: Thu Dec 11, 2008 1:02 pm
Location: Lendava, Slovenia (EU)

Re: CS4 Problem with PostScript 1-Fonts

Post by opeter » Wed Feb 04, 2009 9:24 am

If i'm right, Adobe is slowly canceling the PS fonts support in their future Adobe CS suites. OpenType is the future... If you go to Adobe Store/Fonts, you'll see, that they are selling almost only OTF fonts, the same goes for Font Folio.

Anyway, i hope, Erwin will see this thread and can answer your questions.

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: CS4 Problem with PostScript 1-Fonts

Post by Erwin Denissen » Wed Feb 04, 2009 10:00 am

If PostScript Type 1 fonts installed by other means (e.g. directly through Windows font folder) also fail to display in Adobe Creative Suite 4 Products, I suggest you contact Adobe. If this only affects MainType, then we'll have to look into it.
Erwin Denissen
High-Logic
Proven Font Technology

DennisTeusink
Posts: 1
Joined: Fri Mar 27, 2009 8:57 am

Re: CS4 Problem with PostScript 1-Fonts

Post by DennisTeusink » Fri Mar 27, 2009 9:04 am

Hi,

I tested installing Type1 fonts with MainType 2.1 and the fonts don't show in CS4 products. By installing them directly via the explorer they do show. I think it's a problem with MainType.

I hope to have helped.

Dennis

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: CS4 Problem with PostScript 1-Fonts

Post by Erwin Denissen » Fri Mar 27, 2009 9:23 am

You should use MainType version 2.1.1. Please let us know if that solves the problem. Loading the fonts is fine with most software, but I suspect Adobe software might have problems with that, so I suggest you install the fonts.
Erwin Denissen
High-Logic
Proven Font Technology

Salamalec
Posts: 1
Joined: Thu Apr 02, 2009 10:06 pm

Re: CS4 Problem with PostScript 1-Fonts

Post by Salamalec » Thu Apr 02, 2009 10:12 pm

@Erwin Denissen

Hi,
as a followup: MainType (2.1.1) does not display PS Type 1 fonts in CS4.
Is highlogic working on this issue?

best regards,
jd lafontaine

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: CS4 Problem with PostScript 1-Fonts

Post by Erwin Denissen » Fri Apr 03, 2009 5:19 am

If fonts don't show up in CS4, you should contact Adobe as they are the vendor who developed Creative Suite 4.
Erwin Denissen
High-Logic
Proven Font Technology

fabian
Posts: 4
Joined: Wed May 13, 2009 8:58 am

Re: CS4 Problem with PostScript 1-Fonts

Post by fabian » Wed May 13, 2009 9:11 am

I have the same problem:
PostScript 1-Fonts are accessible within Indesign CS3 and other Applications such as Word, but not within all Apps of the Creative Suite CS4. PostScript 1-Fonts that are installed via the Fonts-Directory of Windows are displayed properly and are working with CS4.
I looked up the Adobe knowledge base, but there seems to be no such problem listed, so I think the problem is Main Type.

Could you please investigate what the problem might be? It's not easy to switch to the new software package as long this problem exists.

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: CS4 Problem with PostScript 1-Fonts

Post by Erwin Denissen » Wed May 13, 2009 10:23 am

When you install the PostScript Type 1 fonts through MainType, do you let MainType copy the font files into Windows font folder? You can enable this setting through Tools -> Options on the Fonts tab.
Erwin Denissen
High-Logic
Proven Font Technology

fabian
Posts: 4
Joined: Wed May 13, 2009 8:58 am

Re: CS4 Problem with PostScript 1-Fonts

Post by fabian » Wed May 13, 2009 10:51 am

With this option enabled it works.

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: CS4 Problem with PostScript 1-Fonts

Post by Erwin Denissen » Wed May 13, 2009 12:48 pm

I'm glad to know that worked. It looks like a serious CS4 bug to me.
Erwin Denissen
High-Logic
Proven Font Technology

fabian
Posts: 4
Joined: Wed May 13, 2009 8:58 am

Re: CS4 Problem with PostScript 1-Fonts

Post by fabian » Wed May 13, 2009 1:12 pm

I opened up a thread in the Adobe support Forums, let's see what comes out of it... :wink:

kiba91
Posts: 1
Joined: Sat May 16, 2009 1:13 pm

Re: CS4 Problem with PostScript 1-Fonts

Post by kiba91 » Sat May 16, 2009 1:31 pm

I all,

Fabian, i have activated the option "copy postscipt to windows font folder" in maintype 2.1 like you suggered, but the font don't appear in cs4 product.

I'm on windows 7 rc x64, and when i selecting this option, my postcript font appears on windows font folder(C:\Windows\Fonts) when i browsing on maintype, but don't appears when i go on C:\Windows\Fonts with the explorer windows folder. So, postscript font don't show on cs4.

When i install directly my postcript fonts without maitype or suitcase, they appears correctly on my C:\Windows\Fonts with explorer and they selectable correctly in cs4 product.

Do someone know how my postscript fonts could be installed and showed directly with maintype?

thanks a lot.

Kiba

fabian
Posts: 4
Joined: Wed May 13, 2009 8:58 am

Re: CS4 Problem with PostScript 1-Fonts

Post by fabian » Tue May 26, 2009 11:45 am

Hi Kiba,

I'm sorry,I can't help you, but I would encourage you to post this problem also in the Adobe forums (see link above).

I noticed a strange thing today: I tried to install a Rotis font with the method desribed above, but it did not show up in Illustrator CS4.
It did show up in Illustrator CS3 and when I copied some text written in Rotis via the clipboard into CS4, it worked. Suddenly, the font showed up in the fonts menu. Not correctly alphabetically sorted, but it worked. I tried this with all Rotis variants, all of them where working when a few characters where copy/pasted into Illustrator.

Erwin, is it possible that you could spend some thoughts on this?

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: CS4 Problem with PostScript 1-Fonts

Post by Erwin Denissen » Tue May 26, 2009 12:39 pm

We are about to release FontCreator 6, and due to the tight schedule we can't look into it right now. We'll investigate this issue as soon as we start working on MainType.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests