Problem Installing Fonts After Invert Selection [Solved]

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Post Reply
Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8481
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK

Problem Installing Fonts After Invert Selection [Solved]

Post by Bhikkhu Pesala » Wed Jan 02, 2013 10:23 pm

II use the following workflow to update fonts after editing and saving from FontCreator
  1. Quick search in MainType 5.0 build 617 to filter by font name
  2. Refresh the font folders
  3. Select the four installed fonts and uninstall them
  4. Invert the selection
  5. Install the four new versions (regular, italic, bold, bold italic)
  6. Invert selection
  7. Remove and ignore the old versions.
This seemed to work OK usually, but I find now that Installing now tries to install 21 fonts, although only four are selected. Apparently, Invert selection is selecting 17 other (ignored) fonts, and the process just stalls. At the time there were 21 ignored versions of Jivata in all four type styles.

FontService.exe is running at 95% CPU, but nothing changes.

To recover the situation, I rebooted, and restored the ignored fonts, then installed the new fonts, and removed the unwanted fonts again.

It may be that I am too quick — trying to remove fonts before the installation of the new ones is complete.
Stalled Install.png
Stalled Install.png (60.38 KiB) Viewed 2910 times
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1909 build 18363.657

Erwin Denissen
Posts: 8438
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands

Re: Problem Installing Fonts After Invert Selection

Post by Erwin Denissen » Fri Jan 11, 2013 9:31 am

This bug is solved in MainType 5.1.
Erwin Denissen
Proven Font Technology

Post Reply