OOPS error message after creating backup

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Post Reply
Stonyjohn
Posts: 1
Joined: Wed Jan 27, 2016 10:27 am

OOPS error message after creating backup

Post by Stonyjohn » Wed Jan 27, 2016 10:58 am

Hi,
I'm evaluating MainType version 6.0 and getting to grips with the interface.

Going into the backup routine through Tools > Create and Restore Backups, and clicking on the Backup and Restore tab, I'm met with a message reading:
"Backup and restore is only available if the fontservice is not running"
So I go back to the Status tab and stop the Font Service. Trying the Backup tab again I can now run the backup routine. When it has completed I then go back to the Status tab and re-start the Font Service. Upon closing the box I then see the OOPS! message telling me that MainType has lost the connection to the font service, and asks me to restart MainType, when in fact the font service had already been restarted.

It seems to me that this entire operation is rather disjointed and the stopping and restarting of the font service could be integrated into the backup routine itself, eliminating the need to a OOPS message. Alternatively, the OOPS message could be dropped once the service has been restarted.

Erwin Denissen
Moderator
Moderator
Posts: 6644
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: OOPS error message after creating backup

Post by Erwin Denissen » Wed Jan 27, 2016 11:43 am

I agree, the process could be made easier, but for now you'll have to restart MainType when the font service has been restarted. It is usually not something people do every hour, so we focused on improving the user interface instead of spending a lot of time improving the backup process.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest