Page 1 of 1

Preview and sample show generic text, even when font has all characters

Posted: Tue Oct 25, 2016 1:42 am
by nabsltd
In MainType 7.0.0, the highlighted font (Mrs Saint Delafield) has all basic latin characters (which you can see from the Characters and Zoom panes), but the preview shows generic:
BadPreview.jpg
BadPreview.jpg (649.47 KiB) Viewed 1687 times
When the font is loaded, Word has no problem displaying the font:
MrsSaintDelafield.jpg
MrsSaintDelafield.jpg (101.96 KiB) Viewed 1687 times
Although the PANOSE information is wildly incorrect, it is perfectly valid:
MrsSaintDelafieldPANOSE.jpg
MrsSaintDelafieldPANOSE.jpg (79.22 KiB) Viewed 1687 times
But, MainType works fine if I set the PANOSE to something more closely resembling the actual font:
MrsSaintDelafield-fixed.jpg
MrsSaintDelafield-fixed.jpg (627.44 KiB) Viewed 1687 times
MrsSaintDelafieldPANOSE-fixed.jpg
MrsSaintDelafieldPANOSE-fixed.jpg (84.87 KiB) Viewed 1687 times
I don't have the time to completely debug the issue and find exactly what PANOSE changes would be enough to make MainType happy, but suffice to say that it should preview correctly without requiring any changes. The font can be freely downloaded from Google, so it shouldn't be a problem exactly recreating the issue.

Re: Preview and sample show generic text, even when font has all characters

Posted: Tue Oct 25, 2016 1:07 pm
by Erwin Denissen
I don't think there is anything wrong with the font. We've recently made some more improvements which will be released with a minor update soon.

In case you don't want to wait; here it is. Do let us know your results.
http://www.high-logic.com/tmp/MainTypeS ... 0.1026.exe

Re: Preview and sample show generic text, even when font has all characters

Posted: Tue Oct 25, 2016 4:30 pm
by Alfred
I've just downloaded the font Mrs Saint Delafield and added it to MainType 7.0 (build 1012, as offered on the download page of this site). The font displays correctly for me, both in the View pane preview and in the Sample pane.

Re: Preview and sample show generic text, even when font has all characters

Posted: Tue Oct 25, 2016 7:10 pm
by nabsltd
Erwin Denissen wrote:In case you don't want to wait; here it is. Do let us know your results.
http://www.high-logic.com/tmp/MainTypeS ... 0.1026.exe
It doesn't fix all fonts that had this issue, but it does seem to fix most. It's hard to find these, because the preview is generic serif, but it looks like only about 10 or so fonts are a problem now, when before it was a lot more (mostly Google fonts, as far as more recently created fonts are concerned).

Re: Preview and sample show generic text, even when font has all characters

Posted: Tue Oct 25, 2016 7:33 pm
by Erwin Denissen
nabsltd wrote:It doesn't fix all fonts that had this issue, but it does seem to fix most.
That is good news.

Do let us know which ones still cause problems.