"Font Name" display/Quick Search is inconsistent

Post your bug reports here. Include information that helps us to understand and reproduce the bug.
Post Reply
nabsltd
Posts: 130
Joined: Tue Oct 18, 2016 12:35 am

"Font Name" display/Quick Search is inconsistent

Post by nabsltd » Tue Jul 17, 2018 9:12 pm

In MainType 8.0.0.1135 (64-bit):

First, what I am describing happens a lot. The two attached files are just examples that can be imported into MainType to verify the issue.

The two attached font files (glyphs replaced with placeholders to avoid copyright issues) both seem to have the exact same configuration for the font properties (as displayed by FontCreator):
  • Font family has spaces in the name
  • Font Subfamily is "Bold"
  • "Extended" names are empty
  • "Full Font Name" has spaces
  • "PostScript Name" has no spaces
The only difference I can see is that the expanded ("Exp") version does not have any custom naming field information, but the other file does not have an entry there for English, so it should not make a difference.

The problem is that these two fonts are displayed with "Font Names" of "Agency FB Bold" and "AgencyFBExp-Bold", even though the displayed "Family" matches the information in the files for both ("Agency FB" and "Agency FB Exp"). This leads to several issues:
  • Sorting by font name separates fonts that often should be together
  • All Windows programs display these fonts with spaces in the names (i.e., "Agency FB" and "Agency FB Exp"), so MainType isn't helping me figure out if I picked the right font to install.
  • Quick Search is more painful, since you have to search for "Agency FB" to find the one font, and "AgencyFB" to find the other. The only way to display both fonts is to search for just "Agency". For fonts with common name parts (like Garamond, Bodoni, etc.), this means you end up with a lot of matches that you don't really want to see.
  • I could just hide the "Font Name" column, and then the "Family" plus "Style" columns will tell me what Windows will see, but then I can't search correctly, since Quick Search only searches on "Font Name".
So, unless somebody can point out why these two files with very similar information absolutely should have the font name display in a completely different way, this is a bug. And, if it isn't a bug, please post a modified "Empty Agency FB Exp-Bold.otf" file where MainType will display the font name correctly (i.e., with spaces, like other Windows programs display it).
Attachments
Empty Agency FB-Bold.otf
(23.87 KiB) Downloaded 9 times
Empty Agency FB Exp-Bold.otf
(9.78 KiB) Downloaded 10 times

Erwin Denissen
Moderator
Moderator
Posts: 7317
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: "Font Name" display/Quick Search is inconsistent

Post by Erwin Denissen » Tue Jul 17, 2018 10:02 pm

Yes, this looks like a bug indeed. Thank you for reporting it. We'll try to fix it with the next upcoming release.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest