Unable to kern certain pairs

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Jonne Haven
Posts: 395
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Unable to kern certain pairs

Post by Jonne Haven » Mon May 18, 2020 11:47 pm

Hey All!

I'm using the latest FontCreator 13 Pro program and have found that I'm unable to kern very specific pairs together. For example if I type in ALL CAPS and write FONTCREATOR in the opentype designer, I am able to kern every pair except for the O and N pair. No matter what the word it's always the pair right after the first pair. This might have to do with my CALT settings but I was able to do this in FontCreator 11...

Erwin, I have emailed you my font file.

Blessings!

Jonne

Erwin Denissen
Moderator
Moderator
Posts: 8620
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Unable to kern certain pairs

Post by Erwin Denissen » Tue May 19, 2020 7:43 am

Do use the proofing tool to see what features and lookups are applied:
Proofing.png
Proofing.png (186.7 KiB) Viewed 185 times
Erwin Denissen
High-Logic
Proven Font Technology

Jonne Haven
Posts: 395
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Re: Unable to kern certain pairs

Post by Jonne Haven » Tue May 19, 2020 11:55 pm

Erwin,

Thanks for the quick response!

I have looked through the problem using the proofing tool which I don't really know much about but I noticed one thing that seemed odd. As you can see in the below picture the proofing tool shows two kerning pairs. The pair preceding the selected letter and the pair after the selected letter. The pair which concerns me is the second one I just mentioned. The previous pair in this case the FO pair is listed after the the ON pair which I think is why when I click on the 'O' the FO kerning pair shows up. It is last in the proofing tool display. To prove this I have moved just the table with the FO kerning pair and put it after the table with the ON kerning pair. Once I did this the kerning worked and the proofing tool showed the appropriate pair last. This fix does not work for my whole font because I have many tables that can't be put in the right order to work because they are just too sophisticated. I think this one needs to be worked out in the software. The problem seems to have nothing to do with my other CALT entries just the kerning tables order because I have tried other kerning pairs that don't use my other CALT entries with the same results. I hope you still have my font file handy, if not I can email it again. Feel free to ask more questions if you don't understand me, I'm not up with the appropriate lingo I know.

Has anyone else come across this problem?
Untitled General before.jpg
Untitled General before.jpg (541.66 KiB) Viewed 161 times
Thanks for the quick work,

Blessings,

Jonne

Erwin Denissen
Moderator
Moderator
Posts: 8620
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Unable to kern certain pairs

Post by Erwin Denissen » Wed May 20, 2020 5:55 am

I've taken another look at the font, but I still don't see anything wrong.

Maybe the kern value of 5 units is too small to make a difference.
Erwin Denissen
High-Logic
Proven Font Technology

Jonne Haven
Posts: 395
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Re: Unable to kern certain pairs

Post by Jonne Haven » Wed May 20, 2020 11:19 pm

Are you able to kern the 'ON' pair?

Jonne

Erwin Denissen
Moderator
Moderator
Posts: 8620
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Unable to kern certain pairs

Post by Erwin Denissen » Thu May 21, 2020 10:06 am

Sure. I did exactly what you did, I used the same preview text. Within the proofing tool, I also clicked the "O", so only rules applied to that glyph are shown. Then still in the proofing tool, I clicked the line "Index 32 33 : O.Gap N.Gap -> kern value (5)".

That caused this rule to become selected in the OpenType Designer window. I then just changed the 5 into 500. And yes, that did make a difference ;-)

Hope this helps.
Erwin Denissen
High-Logic
Proven Font Technology

Jonne Haven
Posts: 395
Joined: Wed Sep 30, 2015 12:02 pm
Location: Kaneohe, Hawaii, USA

Re: Unable to kern certain pairs

Post by Jonne Haven » Thu May 21, 2020 11:40 pm

Erwin!

Thanks again for the quick response!

And thanks for indulging me and explaining things a second time. I see how you were able to kern the problematic pair now. You used the proofing tool to get the OTD to see it. Unfortunately I don't use the proofing tool when I want to do quick work. I wonder if you are able to simply select the ON pair in the preview pane without using the proofing tool? This was possible in FontCreator 11 and I liked that ability because it was quicker than it would be to have to use the proofing tool. Oh and just to clarify, it is not just one kerning pair that won't work the way I'm used to it is many, so you won't think my complaint is being bratty.

Maybe this is just not how it works anymore which I would find sad and in which case I would officially like to request this feature back again. I'll even post it in the feature requests forum ;).

So I guess what I'm asking is can you kern the pair ON without using the proofing tool and if you can't, perhaps consider making a patch for the software to do it in the future? If that's not possible do let me know so I'll stop trying. Thanks Erwin for listening!

Blessings,

Jonne

Erwin Denissen
Moderator
Moderator
Posts: 8620
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Unable to kern certain pairs

Post by Erwin Denissen » Fri May 22, 2020 7:50 am

We haven't change it.

The preview within the OpenType Designer always shows the last applied rule for the specific glyph. You have the kern pairs in two lookups, and that order is the cause.

The proofing tool shows all applied rules, so it is more versatile.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply