Faulty results in Word and others

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Karin1610
Posts: 100
Joined: Sun Jul 23, 2017 9:07 am

Faulty results in Word and others

Post by Karin1610 » Sun Jan 03, 2021 2:45 pm

Hi everyone!
I'm having a very strange problem.
I'm making a cursive school font. It has many versions of each letter, depending on what comes before and after, so it really turns out the way we teach the letters to the kids.
I've set up lots of Chained context substitution rules and in the Font Creator preview everything shows up correctly, like this.
01.jpg
01.jpg (71.03 KiB) Viewed 182 times
However, in other programs (I tried it in Word and Corel Draw) the output looks like that:
02.jpg
02.jpg (21.01 KiB) Viewed 182 times
It calls up the wrong "o", one that is actually called by a rule that comes a little further down.
But not the rule itself seems to be faulty. It's got something to do with the classes. Here's the really weird thing: If I go ahead and add a random glyph to the class that I used for my "Input" (for instance a "1"), it suddenly works. Not all glyphs will help though and I haven't found out which do or don't or why. I don't want to fix this problem like that anyway. I don't want to put a glyph in a class that doesn't belong there.
Any ideas on what might be going on here?
Thanks in advance!

Erwin Denissen
Moderator
Moderator
Posts: 9138
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Faulty results in Word and others

Post by Erwin Denissen » Fri Jan 08, 2021 7:58 pm

Do send the project file to us by email, so we can look into this. I will send you a PM with instructions.
Erwin Denissen
High-Logic
Proven Font Technology

Karin1610
Posts: 100
Joined: Sun Jul 23, 2017 9:07 am

Re: Faulty results in Word and others

Post by Karin1610 » Sat Jan 09, 2021 9:44 am

Thank you, but I have changed things around and got it to work by now. What did the trick was putting the affected rules in a separate subtable. It's funny, the rules are still in the same position as they were before, only in an extra subtable. I don't really understand why, but it works.

Erwin Denissen
Moderator
Moderator
Posts: 9138
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Faulty results in Word and others

Post by Erwin Denissen » Sat Jan 09, 2021 10:53 am

Sounds indeed strange. If it is a bug in FontCreator we would love to have the chance to fix it. So if you still have a copy of your font project with the issue, do send it.
Erwin Denissen
High-Logic
Proven Font Technology

Karin1610
Posts: 100
Joined: Sun Jul 23, 2017 9:07 am

Re: Faulty results in Word and others

Post by Karin1610 » Mon Jan 11, 2021 12:34 pm

Unfortunately I don't. But I'll try to recreate it when I get the chance.

Karin1610
Posts: 100
Joined: Sun Jul 23, 2017 9:07 am

Re: Faulty results in Word and others

Post by Karin1610 » Mon Jan 11, 2021 2:37 pm

Okay, I got it. What email address do I send it to?

Erwin Denissen
Moderator
Moderator
Posts: 9138
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Faulty results in Word and others

Post by Erwin Denissen » Mon Jan 11, 2021 5:41 pm

I have received the font project, but it works just fine in both Word and Firefox.
Erwin Denissen
High-Logic
Proven Font Technology

Karin1610
Posts: 100
Joined: Sun Jul 23, 2017 9:07 am

Re: Faulty results in Word and others

Post by Karin1610 » Wed Jan 13, 2021 5:58 pm

Now that makes the whole thing even stranger. I'm not making this up. I have tried it out a lot of times.

Edit: I just tried it on my laptop too where I have Office 365 whereas on my PC I have Office 2016. Same result.
Then I tried to actually install the font rather than testing it via the F5 function. Same result.
And now I also tried it in LibreOffice and there it also doesn't work.

Post Reply