Font corrupt in Windows XP and Windows 2000, works in Win 98

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
erik schroeder
Posts: 1
Joined: Tue Oct 08, 2002 4:54 pm

Font corrupt in Windows XP and Windows 2000, works in Win 98

Post by erik schroeder » Tue Oct 08, 2002 5:11 pm

I used FCP on my Windows 98 machine to create a font. I installed the font on that machine and on another Win 98 machine, and it worked fine in both places. I tested it in MS Word & Adobe Photoshop.

However, the font will not install or even open in the font viewer on Windows XP or Windows 2000. The error message states that the font is corrupt.

I've compared the properties of my font to those of other fonts already installed on my machine, like Arial and Times New Roman, and can't figure out what the problem might be.

Does anyone have any ideas on how I can get my font to work in Win XP and 2000?

Thanks!

Erwin Denissen
Moderator
Moderator
Posts: 8615
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Post by Erwin Denissen » Tue Oct 08, 2002 8:34 pm

In a TrueType font each platform has its own language items. For each language the Naming fields can be edited in the Naming window.

For the Microsoft (Unicode or Symbol) Platform these naming entries for English - United States should be available:
- Font Family Name
- Font Subfamily Name
- Unique Font Identifier
- Full Font Name
- Version String
- Postscript Name

All these fields should be present, Window 95, 98 and ME don't care about these fields but Windows NT, 2000 and XP require these fields - without these fields installation will fail.

Note: it is recommended to have identical values for all available fields for all available platforms, except for the font subfamily name field, as this field is language dependant.

Erwin Denissen

Russen
Posts: 2
Joined: Fri Oct 18, 2002 2:49 pm

In response...

Post by Russen » Fri Oct 18, 2002 3:03 pm

Hi there - you may have noticed my post in another room.
This is exactly the problem i was having, but this has solved it. thankyou!
Russ

Post Reply