font installation

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Jayashree
Posts: 11
Joined: Mon Apr 01, 2013 3:35 am

font installation

Post by Jayashree » Tue Apr 30, 2013 9:02 am

I am not able to install my font from fontcreator7.0 , before installation it says "The font "NAVLIPI" is already installed. Currently the file is located at:
"c:\windows\fonts\navlipi.otf"". When I do a search on c:\windows\fonts folder I cannot find the font file. When I click on 'finish' it says "Could not complete font installation: Font installation failed."

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8843
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: font installation

Post by Bhikkhu Pesala » Tue Apr 30, 2013 10:31 am

If FontCreator says that the font is installed, then it probably is. The font folder can be sorted by date modified to make it easier to find recently installed fonts.
My FontsReviews: MainTypeFont CreatorHelpFC13 Pro + MT10.0 @ Win10 1909 build 18363.959

Jayashree
Posts: 11
Joined: Mon Apr 01, 2013 3:35 am

Re: font installation

Post by Jayashree » Wed May 01, 2013 4:15 am

I sorted on date modified as you suggested but could not find the file.

Jayashree
Posts: 11
Joined: Mon Apr 01, 2013 3:35 am

Re: font installation

Post by Jayashree » Wed May 01, 2013 4:20 am

what are the other reasons that a font intallation can fail?

Alfred
Top Typographer
Top Typographer
Posts: 1028
Joined: Thu Apr 18, 2013 8:08 am

Re: font installation

Post by Alfred » Wed May 01, 2013 12:06 pm

A font installation can fail because the font file is corrupt, but if FontCreator says that the font is already installed, then that must be the reason for the failure.

What version of Windows do you have, and how are you performing the search? If I go to the Windows Fonts folder on this Win7 system and type n in the Search box, it shows me the fonts which have 'n' at the beginning of one of the words in the name (plus a few that don't!). If I change the search string to na, the results are filtered still further (as you would expect). In my case, nap returns a couple of fonts with 'Napa' in the name but nav returns no results because I don't have any installed fonts fitting that criterion.
FC11.5 Pro (Help) + MT8.0 Pro (Help) • Windows 10

Jayashree
Posts: 11
Joined: Mon Apr 01, 2013 3:35 am

Re: font installation

Post by Jayashree » Wed May 01, 2013 1:24 pm

I did exactly whatyou have mentioned and it says 'no items match your search'. There only 5 fonts starting with n- narkisim, Niagara engraved, niagara solid, NSIM Sun and nyala in my windows/fonts folder. I will upload my font file. Please check if there is way to say it is corrupt.
Attachments
NAVLIPI.otf
(79.27 KiB) Downloaded 164 times

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8843
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: font installation

Post by Bhikkhu Pesala » Wed May 01, 2013 2:31 pm

If I try to install it, I get the installation failed message.

If I try again, then I get the "Font is already installed" message. If I then open the Window Font folder, then it is there, and can be deleted.

Then I can go back to stage 1 again.

After validation, and removing all errors (contours with wrong directions, and intersecting co-ordinates), it still won't install.

If I double-click NAVLIPI.otf in Windows Explorer, I get an error message that its not a valid font file. Other *.otf files will open in FontView.

MainType doesn't find the font when I refresh the font library. I guess that its corrupted or protected in some way.

It was produced by FontLab.
My FontsReviews: MainTypeFont CreatorHelpFC13 Pro + MT10.0 @ Win10 1909 build 18363.959

Jayashree
Posts: 11
Joined: Mon Apr 01, 2013 3:35 am

Re: font installation

Post by Jayashree » Wed May 01, 2013 3:25 pm

How do I resolve this issue?

Erwin Denissen
Moderator
Moderator
Posts: 8899
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: font installation

Post by Erwin Denissen » Wed May 01, 2013 4:00 pm

The errors you received from FontCreator might have mislead you. Sorry for that. I'll see if we can improve this further.

The font file has invalid values for Win Ascent and Win Descent.
invalidmetrics.png
invalidmetrics.png (59.94 KiB) Viewed 4321 times
Click the Calculate button and try again.
Erwin Denissen
High-Logic
Proven Font Technology

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8843
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: font installation

Post by Bhikkhu Pesala » Wed May 01, 2013 10:00 pm

I found that the font installed correctly after recalculating the metrics.

Note that the original font has a lot of validation errors, particularly contours with incorrect direction and intersecting co-ordinates, which might cause problems, although they might not prevent the font from being installed.
Validation Errors.png
Validation Errors.png (20.74 KiB) Viewed 4314 times
I attach the project file with all of the validation errors fixed.
Attachments
NAVLIPI.fcp
(46.9 KiB) Downloaded 172 times
My FontsReviews: MainTypeFont CreatorHelpFC13 Pro + MT10.0 @ Win10 1909 build 18363.959

Jayashree
Posts: 11
Joined: Mon Apr 01, 2013 3:35 am

Re: font installation

Post by Jayashree » Thu May 02, 2013 4:33 am

Thanks. I will work on fixing the errors and try to install.

Post Reply