Kerning added, but doesn't work

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Lucas
Posts: 9
Joined: Wed Feb 04, 2015 10:42 am

Kerning added, but doesn't work

Post by Lucas » Fri Aug 28, 2015 12:45 pm

Hello Guys,

I have a problem with kerning in my font.

My version of FC is 8 Pro. I wanted to add a kerning for some pairs in my font through OpenType Designer, as following:
kerning.jpg
kerning.jpg (261.92 KiB) Viewed 1416 times
I click "save" and there are simply no changes in font. I don't know why. I need any additional functions or...?

.otf of the font is in attachment.

I think it could be a matter of minutes for some of you. Could you help, please?
Attachments
New York Pik.otf
(24.84 KiB) Downloaded 115 times

Erwin Denissen
Moderator
Moderator
Posts: 8321
Joined: Fri Oct 04, 2002 12:41 am
Location: Bilthoven, The Netherlands
Contact:

Re: Kerning added, but doesn't work

Post by Erwin Denissen » Fri Aug 28, 2015 1:29 pm

You are indeed very close.

For the lookup (PairAdjustment1) to work, it has to be tied to a feature (Kerning1), as you already did, but then that feature needs to be connected to a language (default), which in turn belongs to a script (Latin).

So in your case, right-click the default language and select New Item from the context menu. From there you can select the kerning feature. It then should look similar to this:
makekernwork.png
makekernwork.png (114.79 KiB) Viewed 1419 times
Last edited by Bhikkhu Pesala on Fri Aug 28, 2015 2:33 pm, edited 1 time in total.
Reason: Correct typo
Erwin Denissen
High-Logic
Proven Font Technology

Lucas
Posts: 9
Joined: Wed Feb 04, 2015 10:42 am

Re: Kerning added, but doesn't work

Post by Lucas » Mon Aug 31, 2015 8:21 am

Hey Erwin!

Thank you so much for your time and effort - everything works perfectly! :) It was not clear to me before and now is.

Cheers, thanks one more time!
Have a great day.

Post Reply