Page 1 of 1

problem about CJK compatibility forms

Posted: Sun Oct 04, 2015 1:46 pm
by yucong
hello,I'm a new designer with fontcreator.now,I met a big problem.I designed CJK symbols and punctuation,CJK compatibility forms.But,CJK compatibility forms can't use. for example.I write 《china》,when I turned it to vertical typo,I want《》can change presentation form for vertical left or right double angle bracket,but ,they don't change.what can I do? I still can't solve this problem :oops: :oops: :oops:

Re: problem about CJK compatibility forms

Posted: Sun Oct 04, 2015 1:50 pm
by Erwin Denissen
I'm not sure, but maybe your font lacks some characters or it is missing specific OpenType layout features.

Do you happen to know fonts that do work correctly?

Re: problem about CJK compatibility forms

Posted: Sun Oct 04, 2015 2:53 pm
by yucong
thanks for your answer.In addition to the CJK compatibility forms (eg:《》{}【】())other fonts do work correctly.I guess maybe miss specific Opentype layout features like you said.May I do some setting in Opentype Designer?because I don't know how to programming. :oops: :oops:

Re: problem about CJK compatibility forms

Posted: Sun Oct 04, 2015 3:58 pm
by Erwin Denissen
Do let us know which fonts work, so we can better understand the issue.

Re: problem about CJK compatibility forms

Posted: Tue Oct 06, 2015 1:25 pm
by yucong
I know Microsoft YaHei by Microsoft Corporation in 2008 do work correctly. Thank you very much.

Re: problem about CJK compatibility forms

Posted: Wed Oct 07, 2015 8:37 am
by Erwin Denissen
Yes, this is definitely due to missing OpenType layout features. See the screenshot where you see the vertical writing feature in action:
VerticalWriting.png
VerticalWriting.png (114.96 KiB) Viewed 3589 times
For your font to support this, you need to add similar features.

This script (import it or paste it in the Code Editor) should get you started:

Code: Select all

script hani {
  feature VerticalWriting;
}

feature VerticalWriting vert {
  lookup SingleSubstitution1;
}

lookup SingleSubstitution1 {
  sub arrowleft -> arrowup;
  sub arrowup -> arrowright;
  sub arrowright -> arrowdown;
  sub arrowdown -> arrowleft;
  sub uni2225 -> uni2225.v;
  sub uniFF08 -> uniFE35;
  sub uniFF09 -> uniFE36;
  sub uniFF1D -> uniFF1D.v;
  sub uniFF3B -> uniFE47;
  sub uniFF3D -> uniFE48;
  sub uniFF3F -> uniFE33;
  sub uniFF5B -> uniFE37;
  sub uniFF5D -> uniFE38;
  sub uni3008 -> uniFE3F;
  sub uni3009 -> uniFE40;
  sub uni300A -> uniFE3D;
  sub uni300B -> uniFE3E;
  sub uni3010 -> uniFE3B;
  sub uni3011 -> uniFE3C;
}
Let us know if you need additional help with this.

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 1:38 am
by yucong
I'm very appreciate for your help.I'll try it now.

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 1:48 pm
by yucong
hello,Erwin Denissen.I met a new problem.when I copied script in code page ,I press action,it occured:
Compiling script...
[Error] : Linker error: Unable to link "arrowleft" to a glyphid
Failed
Elapsed time: 00:00:00.0



and then I still can't find "single substitution1"beyond vertical writing.
how can I do to let you see the screenshot?

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 2:20 pm
by Erwin Denissen
You need to ensure your font contains a glyph with name arrowleft so the compiler can find the correct glyph. In this case it should represent character with codepoint $2190.

If you don't want these characters and glyphs, then simply remove those lines and recompile.

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 2:53 pm
by yucong
I removed some characters,it occured:compiling script success.then I saved the script.I went to opentype designer,the step is :CJK Ideographic(hani)...Default...Verticalwriting1(vert).get to Verticalwriting1(vert),I choose "new item",it have five options:single adjustment;pair adjustment;mark to base attachment;mark to mark attachment;chained context positioning.But still don't have single subsititution.what's wrong with me?
'

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 3:26 pm
by Erwin Denissen
It seems you are still using an older version of FontCreator. For this to work I recommend you upgrade to version 9.

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 3:41 pm
by yucong
by the way ,I use fontcreator 8.0 professional edition.thank you.

Re: problem about CJK compatibility forms

Posted: Fri Oct 09, 2015 3:43 pm
by yucong
I just bought fontcreator 8.0 in January 2015. :x

Re: problem about CJK compatibility forms

Posted: Sun Oct 11, 2015 2:12 pm
by yucong
hello,Erwin Denissen .I have a small question.After I upgrade to fontcreator9.0,these font I was made with fontcreator8.0 could import to new version?or old version still can use?