Page 1 of 1

I got interesting results that embedded font into pdf

Posted: Thu Oct 15, 2015 6:44 am
by jiuntingchen
I used FontCreator 4.x to generate font.
I used it to generate the pdf file.
It is correct, when I used the Adobe Acrobat Reader or Microsoft Reader to open it in Windows 8.

I used FontCreator 9 to generate font.
when I used the Microsoft Reader to open it in Windows 8, something interesting will be happened.
wrong.jpg
wrong.jpg (23.27 KiB) Viewed 3050 times
I think something wrong in the ttf.

Re: I got interesting results that embedded font into pdf

Posted: Thu Oct 15, 2015 7:06 am
by William
What happens if you open the pdf in Adobe Reader please?

William

Re: I got interesting results that embedded font into pdf

Posted: Thu Oct 15, 2015 8:21 am
by Bhikkhu Pesala
Are you using a registered version of FontCreator 9.0?

Did you export your font with TTF or CFF outlines?

If you can attach the TTF and the font project file it will be easy to test to see if we also get a blank PDF.

Re: I got interesting results that embedded font into pdf

Posted: Thu Oct 15, 2015 9:15 am
by jiuntingchen
Bhikkhu Pesala wrote:Are you using a registered version of FontCreator 9.0?

Did you export your font with TTF or CFF outlines?

If you can attach the TTF and the font project file it will be easy to test to see if we also get a blank PDF.
I created the ticket(729218), that has more information.

I using a registered version of FontCreator 9.0.

I can attach the TTF and font project, how can I test it?

Re: I got interesting results that embedded font into pdf

Posted: Thu Oct 15, 2015 9:16 am
by jiuntingchen
William wrote:What happens if you open the pdf in Adobe Reader please?

William
If I opened thd pdf in Adobe Reader, everything is ok.

Re: I got interesting results that embedded font into pdf

Posted: Sat Oct 17, 2015 11:52 am
by jiuntingchen
In Microsoft Word, I got the same result.
abc.jpg
abc.jpg (4.78 KiB) Viewed 3024 times

Re: I got interesting results that embedded font into pdf

Posted: Sat Oct 17, 2015 6:19 pm
by Erwin Denissen
It shows just fine here.

It would help if you could send us the incorrect font file along with a Word document for testing.

Re: I got interesting results that embedded font into pdf

Posted: Sun Oct 18, 2015 8:21 pm
by Erwin Denissen
The incorrect font file you send earlier today is not modified with FontCreator but with some other tool. I suggest you just use FontCreator and if that also fails, let us know so we can fix and improve our software.

Re: I got interesting results that embedded font into pdf

Posted: Mon Oct 26, 2015 1:45 pm
by Erwin Denissen
I was able to track down the problem which fortunately is not related to FontCreator 9. Somehow the hinting data was corrupt; due to using another font editing tool.

Re: I got interesting results that embedded font into pdf

Posted: Tue Oct 27, 2015 8:02 am
by jiuntingchen
Erwin told me, I can disable "hinting" and "OpenType Layout Features", I got the right result.

I tried to upgrade the autottfhint on http://www.freetype.org/ttfautohint/doc ... ohint.html .
I can enable "hinting" and "OpenType Layout Features".

Thanks for the help of Erwin.

Re: I got interesting results that embedded font into pdf

Posted: Tue Oct 27, 2015 8:05 am
by jiuntingchen
I didn't use another font editing tool.
I only used fc 4/8/9.

Re: I got interesting results that embedded font into pdf

Posted: Tue Oct 27, 2015 9:02 am
by Erwin Denissen
jiuntingchen wrote:Erwin told me, I can disable "hinting" and "OpenType Layout Features", I got the right result.

I tried to upgrade the autottfhint on http://www.freetype.org/ttfautohint/doc ... ohint.html .
I can enable "hinting" and "OpenType Layout Features".
Thank you for your feedback. I'm glad we were able to solve the problem.
jiuntingchen wrote:Thanks for the help of Erwin.
You are welcome. Enjoy the software!
jiuntingchen wrote:I didn't use another font editing tool.
I only used fc 4/8/9.
FontCreator version 4 was released over 10 years ago. Over the years we've fixed numerous bugs, and I honestly can't remember all of them. Better uninstall version 4 and 8 :wink: