changing a regular font to italic

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
rcmathen
Posts: 2
Joined: Thu Jul 01, 2004 3:36 pm

changing a regular font to italic

Post by rcmathen » Thu Jul 01, 2004 3:46 pm

I have followed the help but can not change the GulimChe.ttf to italic.

need ASAP.

Please help.

Robert

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8345
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

changing a regular font to italic

Post by Bhikkhu Pesala » Thu Jul 01, 2004 8:12 pm

I just tested with a Devanagari font.

First, make sure you have the latest version of Font Creator from the announcements forum.
  • Open your font. Don't select any glyphs unless you want to leave some glyphs without a slant.
  • From the tools menu, select Glyph Transformer
  • Remove all transformatons from the right panel
  • Add the Skew transformation
  • Click OK to skew all the glyphs in the font
If you're not quite happy with the result, you can try different values for the skew. Note that this poweful feature lacks any undo option. The only way is to close without saving and reopen the original font.

You will, of course, have to save your new font under a new TTF filename, change some values under Format, Settings to identify it as an italic variant, before using the autonaming feature to rename it.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.356

rcmathen
Posts: 2
Joined: Thu Jul 01, 2004 3:36 pm

You da man

Post by rcmathen » Mon Jul 05, 2004 1:30 pm

This is some of the best news I have had over this issue.

Thanks a million.

vanisaac
Posts: 337
Joined: Sun Mar 30, 2003 1:33 pm
Location: Washington State, USA

Post by vanisaac » Sat Jul 10, 2004 7:27 am

Just remember that slanting a roman does not make a true italic. An italic font has several distinguishing properties apart from the slant, including serifing distinct from a roman of the same family.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8345
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Post by Bhikkhu Pesala » Sat Jul 10, 2004 2:48 pm

I don't think that the Romans invaded Korea. :)
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.356

Thapper
Posts: 20
Joined: Mon Jul 12, 2004 12:21 pm
Location: Uppsala, Sweden

Post by Thapper » Mon Jul 12, 2004 12:37 pm

When I make an italic font out of my normal font using the skew option of the glyph-transformer, the "left side bearing" of my glyphs stays with the same. In this case this is not very useful for letters like T where the left-most point of the glyph is far above the baseline. To fix things I have to adjust the x-value (that is the x-value mentioned after "white space before character" in the properites window) to the same value for all glyphs by adjusting the left side bearing value. Since this is a rather boring procedure I only wonder if I missed some option to avoid this problem...

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8345
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Glyph Transformer

Post by Bhikkhu Pesala » Mon Jul 12, 2004 5:11 pm

As well as skew, add the transformation under metrics "Left side-bearing point at x=0"

There are other transformations too, and they are all adjustable.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.356

vanisaac
Posts: 337
Joined: Sun Mar 30, 2003 1:33 pm
Location: Washington State, USA

Post by vanisaac » Wed Jul 14, 2004 3:28 am

Bhikkhu Pesala wrote:I don't think that the Romans invaded Korea. :)
That's even better! A Korean font with an italic? That not only doesn't make sense (no offence rcmathen), but distinctly ignores Korean and east Asian typographic tradition and pragmatic usage.

Post Reply