Blurry Font

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Dichi
Posts: 5
Joined: Sun Feb 14, 2016 12:13 pm

Blurry Font

Post by Dichi » Sat Jul 02, 2016 9:37 am

I noticed that my font looks blurry especially on small sizes. Tested using Google Chrome and Microsoft Edge. I used Roboto as comparison.

My font
Image

Roboto
Image

Is it has something to do with hinting? I tried many different methods of hinting in fontcreator but still results the same.

Auto hinting DO sharpen the looks, but... it also makes my font looks condensed
http://puu.sh/pNzsX/34548bae60.png

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7454
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Blurry Font

Post by Bhikkhu Pesala » Sat Jul 02, 2016 10:15 am

Dichi wrote:Is it has something to do with hinting? I tried many different methods of hinting in fontcreator but still results the same.
There is only one method of hinting in FontCreator, which uses ttfautohint. The only other options are to retain the existing hinting (if any) or to remove hinting.

If you download the ttfautohint package there's a GUI version that you can use to hint your fonts. That has some different options that you can try. I have not tried using it as I find the default setting used by FontCreator is satisfactory.
My FontsReviews: MainTypeFont CreatorHelpFC11.5 Pro + MT8.0 @ Win10 1803 build 17134.345

Dichi
Posts: 5
Joined: Sun Feb 14, 2016 12:13 pm

Re: Blurry Font

Post by Dichi » Sat Jul 02, 2016 10:28 am

Thank you for the reply! I will use the software as suggested.

Erwin Denissen
Moderator
Moderator
Posts: 7350
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Blurry Font

Post by Erwin Denissen » Sat Jul 02, 2016 12:10 pm

Be aware hinting is only added to TrueType based OpenType fonts.
Erwin Denissen
High-Logic
Proven Font Technology

Dichi
Posts: 5
Joined: Sun Feb 14, 2016 12:13 pm

Re: Blurry Font

Post by Dichi » Sat Jul 02, 2016 12:32 pm

I've tried all the settings but there's no change. Maybe I need to rework the font once again. By the way, thank you for the support!

Post Reply