Bold-Italic Formatting issues

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Simeon out West
Posts: 3
Joined: Sat Sep 03, 2016 5:46 am

Bold-Italic Formatting issues

Post by Simeon out West » Sat Sep 03, 2016 6:06 am

Good evening,

I am having difficulty getting the bold-italic version of fonts created in Font Creator to display.

Under the Settings and Metrics, both Bold and Italic are checked.

Have I missed a setting somewhere?

Brett Johnson
Simeon out West

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8381
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Bold-Italic Formatting issues

Post by Bhikkhu Pesala » Sat Sep 03, 2016 6:25 am

Which version of FontCreator are you using?

In FontCreator 6.5, which is the oldest I have installed, the style is set on the Classification tab of the Font Settings dialogue.
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

William
Top Typographer
Top Typographer
Posts: 1998
Joined: Tue Sep 14, 2004 6:41 pm
Location: Worcestershire, England
Contact:

Re: Bold-Italic Formatting issues

Post by William » Sat Sep 03, 2016 8:29 am

Is this of any help?

viewtopic.php?f=3&t=3098

William

Simeon out West
Posts: 3
Joined: Sat Sep 03, 2016 5:46 am

Re: Bold-Italic Formatting issues

Post by Simeon out West » Sat Sep 03, 2016 2:54 pm

Mr Pesala,

I am using version 5.6

Simeon out West
Posts: 3
Joined: Sat Sep 03, 2016 5:46 am

Re: Bold-Italic Formatting issues

Post by Simeon out West » Sat Sep 03, 2016 3:08 pm

Mr Overington ,

Thank you. I actually found the solution in this thread: viewtopic.php?f=3&t=2157
"The problem was that although I had set the font as bold in the Font Settings... Metrics dialogue panel, I had not added the fact that the font is bold on the Format Settings... General panel as well."

When I checked that, I had the same problem. Metrics = yes, general panel = no. Correcting the general panel solved my problem.

Mr. Pesala Forgive me if I have addressed yo uincorrectly),

Thank you for your willingness to help as well. I am using Version 5.6 professional. Apparently using the glyph transformer for bold and italic did not correct all the settings as I assumed that it did.

Brett Johnson
Simeon out West

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 8381
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Bold-Italic Formatting issues

Post by Bhikkhu Pesala » Sat Sep 03, 2016 7:10 pm

Simeon out West wrote:Mr. Pesala Forgive me if I have addressed you incorrectly),
It's not important, but f you want to use the correct form of address it's "Bhikkhu Pesala," as the first part of my name is a title like "Reverend."
Simeon out West wrote:I am using Version 5.6 professional. Apparently using the glyph transformer for bold and italic did not correct all the settings as I assumed that it did.
Version 5.6 was the first that corrected the flag for italics. Correcting the flag for bold was new only in FontCreator 9.0.
Bold Italic.png
Bold Italic.png (14.19 KiB) Viewed 1590 times
My FontsReviews: MainTypeFont CreatorHelpFC12 Pro + MT9.0 @ Win10 1903 build 18362.418

Post Reply