Version 10 continued autohinting issues

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
Typewhisperer
Posts: 73
Joined: Sat Sep 24, 2016 4:36 pm

Version 10 continued autohinting issues

Post by Typewhisperer » Sat Sep 24, 2016 5:08 pm

Iʼve purchased FontCreator 10 Standard, hoping it might resolve the well‑known issue with autohinting. Alas, it didnʼt.

In an online chat with High‑Logic, I was assured that it would be possible to acquire Version 9.1 (which didnʼt have that problem), under the umbrella of my version 10 license. How do I go about that?

Thx in advance,
Typewhisperer

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7083
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Version 10 continued autohinting issues

Post by Bhikkhu Pesala » Sat Sep 24, 2016 5:24 pm

What is this well known issue? Are you exporting postscript outlines?

Be aware hinting is only added to TrueType based OpenType fonts.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703

Typewhisperer
Posts: 73
Joined: Sat Sep 24, 2016 4:36 pm

Re: Version 10 continued autohinting issues

Post by Typewhisperer » Sat Sep 24, 2016 8:19 pm

Hi Bhikkhu,

Iʼm well aware of the constraints concerning autohinting. Iʼve used it successfully with previous versions of FontCreator (like version 9.1). Since version 10, I continually get error messages, and the — same — font gets compiled without ANY hinting at all (much worse than ever before). Quite a number of people in the respective forums (fora?) have complained about exactly the same problem.

Suggested causes (and solutions) were too much complexity due to nested composites. Same as other people, I reduced the complexity, but with the same negative result. The point is that this was never an issue with previous versions, including version 7.

Another problem area is joining outlines (“union”). Whereas previous version (e·g· version 8.0) did joining shapes without delay and rarely with errors, in version 10 it takes ages, and frequently ends in hangs.

Thatʼs why I asked to be able to install version 9.1 and get the respective registration code, since I have paid for the standard version 10. Is there any established way to do this?

Regards.

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version 10 continued autohinting issues

Post by Erwin Denissen » Sun Sep 25, 2016 7:29 am

Typewhisperer wrote:Iʼve purchased FontCreator 10 Standard, hoping it might resolve the well‑known issue with autohinting. Alas, it didnʼt.

In an online chat with High‑Logic, I was assured that it would be possible to acquire Version 9.1 (which didnʼt have that problem), under the umbrella of my version 10 license. How do I go about that?
FontCreator uses the same version of the auto hinter since FontCreator 9.1.0.1991, so I don't think downgrading to that version will fix the problem.

We will contact you to help you solve this issue.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 6903
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version 10 continued autohinting issues

Post by Erwin Denissen » Tue Sep 27, 2016 7:05 am

I've received the font project and discovered two issues. One problem is due to a class which contains several entries of the same glyph. This is not allowed, so it should be fixed. The next upcoming release will provide some more useful feedback when compiling such OpenType layout script, so it is more easy to find and fix this. While testing this, we also discovered a bug related to pair positioning, which is also solved.

The other issue you mentioned relates to the auto hinter, and I can confirm this is an issue. In order to solve that problem as well it is best to contact the main developer of ttfautohint. I'll send you contact details by email.

You also referred to the join feature which seems to fail a lot easier than prior versions. We are working on this issue right now; I'll contact you as soon as we've improved this, so you can happily continue to use version 10.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest