Test TTF/OTF fails V9.1 pro Win10

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
westdale
Posts: 4
Joined: Wed Mar 29, 2017 6:09 pm
Location: UK

Test TTF/OTF fails V9.1 pro Win10

Post by westdale » Thu Mar 30, 2017 12:21 pm

I wish to add a ligature table to an open source font so I do not have to select them manually for each instance.
The Test TTF/OTF command - which has worked fine for me on several fonts to adjust kerning etc - fails to use the open font and defaults to some standard sans font.
Is there something that would prevent this - the font, Alegreya, works fine in print.
I emphasise that this failure occurs before I have changed anything and for small test strings consisting of ordinary latin chars such as 'Abc'.

Any ideas gratefully received.
Apologies if this is a repeat but I have not found a similar question.

Erwin Denissen
Moderator
Moderator
Posts: 6644
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Test TTF/OTF fails V9.1 pro Win10

Post by Erwin Denissen » Thu Mar 30, 2017 1:01 pm

We can't say for sure, but it is likely an issue within FontCreator version 9. Upgrading to the latest version should solve the problem.
Erwin Denissen
High-Logic
Proven Font Technology

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6899
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Test TTF/OTF fails V9.1 pro Win10

Post by Bhikkhu Pesala » Thu Mar 30, 2017 5:26 pm

If you can attach the font project file I can take a look at it.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703

westdale
Posts: 4
Joined: Wed Mar 29, 2017 6:09 pm
Location: UK

Re: Test TTF/OTF fails V9.1 pro Win10

Post by westdale » Thu Mar 30, 2017 10:05 pm

Thanks for the offer ... FCP attached
As a one-person outfit I have to watch the pennies and don't want to spend on upgrade unless sure that is the problem!

regards
Gareth
Attachments
Alegreya-Regular.fcp
(37.11 KiB) Downloaded 11 times

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6899
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Test TTF/OTF fails V9.1 pro Win10

Post by Bhikkhu Pesala » Thu Mar 30, 2017 10:25 pm

The font contains only a kern feature, no Standard Ligatures feature. There are glyphs for fi, fl, and fj, but no feature or lookups.
  1. Open the OpenType Designer
  2. Select the Default language for the Latin script
  3. Click the green [+] button to add a feature
  4. Select the Standard Ligatures feature
  5. With the Standard Ligatures feature selected, click the green [+] button again to add a lookup
  6. Add a Ligature substitution
  7. Select the empty substitution table and click the other green [+] button to add a substitution
  8. Select "f" for the input and the "fi" ligature for the output
  9. Edit the input to "f i"
  10. Repeat for "f l" and "f j"
Add fi substitution.png
Add fi substitution.png (35.2 KiB) Viewed 299 times
Attachments
Alegreya-Regular.fcp
(37.51 KiB) Downloaded 7 times
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703

westdale
Posts: 4
Joined: Wed Mar 29, 2017 6:09 pm
Location: UK

Re: Test TTF/OTF fails V9.1 pro Win10

Post by westdale » Sat Apr 01, 2017 10:33 am

Yes, that is what I intended to do - and thank you for for confirming I was going to do it the right way.

My problem is with the Test as TTF/OTF action.
In the attached image, in the Open Type screen, the font shows correctly; in the test window it shows as Arial or similar.
That is before I made any changes to the font.

If there is something I can do to the font so the test screen works correctly, I shall do that as well.
As a retired person working for charities, I can't really afford £100 to fix a bug :-(
Attachments
fail.jpg
fail.jpg (109.41 KiB) Viewed 271 times

westdale
Posts: 4
Joined: Wed Mar 29, 2017 6:09 pm
Location: UK

Re: Test TTF/OTF fails V9.1 pro Win10

Post by westdale » Sat Apr 01, 2017 11:57 am

The fonts I have manipulated in the past have been fine (such as 'Little Lord Fontleroy' to which I added ligatures for work on some posters).

I thought I would try some 'respectable' fonts ( that is, not open source etc ) and I find that some fonts that came with Illustrator do not work - Adobe Caslon Pro, Adobe Garamond Pro, Arno Pro, Minion .... and several others.
In all these the "test font as WOFF" works ok.

Does that help to narrow down the issue?

Erwin Denissen
Moderator
Moderator
Posts: 6644
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Test TTF/OTF fails V9.1 pro Win10

Post by Erwin Denissen » Sat Apr 01, 2017 12:27 pm

A solution would be to upgrade, but a work around might be to export with TrueType based outlines.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests