Wrong outlines loaded

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
nabsltd
Posts: 52
Joined: Tue Oct 18, 2016 12:35 am

Wrong outlines loaded

Post by nabsltd » Wed Apr 19, 2017 3:51 pm

When opening the attached font file with FontCreator 10.1.0, the outlines are not the ones that appear to be in the font from all other ways of looking at it.
Here's the font as it appears in MainType:
MainTypeView.jpg
MainTypeView.jpg (132.25 KiB) Viewed 273 times
And, here is it opened in FontCreator:
FontCreatorView.jpg
FontCreatorView.jpg (259.1 KiB) Viewed 273 times
My only thought was that some other font file was interfering, but I don't have a font by that same name anywhere else on the system. Is there any setting in a font file that can cause it to render as italic/slanted even though the outlines are not?
Attachments
Eurostile Bold Oblique.otf
(24.82 KiB) Downloaded 14 times

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 6932
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Wrong outlines loaded

Post by Bhikkhu Pesala » Wed Apr 19, 2017 4:44 pm

This is not a bug in FontCreator. The italic flag is enabled in Font Properties.
Italic Flag.png
Italic Flag.png (2.96 KiB) Viewed 268 times
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1703

nabsltd
Posts: 52
Joined: Tue Oct 18, 2016 12:35 am

Re: Wrong outlines loaded

Post by nabsltd » Sun Apr 23, 2017 3:36 pm

Bhikkhu Pesala wrote:This is not a bug in FontCreator. The italic flag is enabled in Font Properties.
OK, so then the FontCreator bug is that the preview on FontCreator doesn't show the font in italics, like every other program does. Also, the "test current font as TTF/OTF" view doesn't show the italics.

Both of these should display the font rendered as it will actually render by any other software.

Erwin Denissen
Moderator
Moderator
Posts: 6660
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong outlines loaded

Post by Erwin Denissen » Sun Apr 23, 2017 4:30 pm

There is indeed something fishy with this font.

I'll see if I can locate the issue.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 6660
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Wrong outlines loaded

Post by Erwin Denissen » Sun Apr 23, 2017 6:13 pm

This bug will be fixed with the next major release.
Erwin Denissen
High-Logic
Proven Font Technology

nabsltd
Posts: 52
Joined: Tue Oct 18, 2016 12:35 am

Re: Wrong outlines loaded

Post by nabsltd » Tue Apr 25, 2017 2:22 am

Erwin Denissen wrote:This bug will be fixed with the next major release.
Thanks. Glad to know I'm not going crazy.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests