Troubleshooting - Invalid Characters

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
owen
Posts: 3
Joined: Thu Jul 27, 2017 8:30 am

Troubleshooting - Invalid Characters

Post by owen » Thu Jul 27, 2017 8:52 am

I trying to reuse some old ttf fonts that were created with old versions of FontCreator (a mixture of version 3.0 and 5.5). I was struggling to get a particular tool to accept them, so I tried loading them up in the latest (evaluation) version of FontCreator to see if it could flag up any issues with them. Straight away from launch the left hand filter tree included an "Invalid Characters" section under "Troubleshooting". This appears to include every character in the font.

Separately I ran the validation wizard which found various "Validation Issues" which I was able to fix (without exporting), but this doesn't seem to have impacted the "Invalid Characters". I don't understand what rules/errors cause characters to appear in the "Invalid Characters" section, I have searched through the documentation and there doesn't seem to be any mention of it. Has anyone got any suggestions of what to look for?

Erwin Denissen
Moderator
Moderator
Posts: 7256
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Troubleshooting - Invalid Characters

Post by Erwin Denissen » Thu Jul 27, 2017 9:05 am

It can be that you've placed outlines too far away from the visible glyph area. Do send us the font project file, and we'll look into this.
Erwin Denissen
High-Logic
Proven Font Technology

owen
Posts: 3
Joined: Thu Jul 27, 2017 8:30 am

Re: Troubleshooting - Invalid Characters

Post by owen » Thu Aug 03, 2017 7:54 am

Thanks for the suggestion. Unfortunately I don't think I am permitted to upload the font, so this might make it quite difficult. I have looked at a few glyphs marked as invalid and not found any so far that got outside of the visible glyph area, though its possible that is causing some of them to be invalid and I have just not found any examples of that yet.

Looking at one of the ttf fonts I have found something that might be interesting. It has 56 glyphs and only 1 is included in the "Invalid Characters" section. The invalid glyph "fraction" is blank/empty. There are also several other glyphs that appear to be empty which are not included in the "Invalid Characters" section. I think all the blank glyphs are intentional, not sure why though. Can you think of anything to look for to compare between an empty invalid glyph and an empty valid glyph?

Does the "Invalid Characters" filter get re-evaluated whenever a glyph is edited or do I need to run something like the validation wizard to update it?

Erwin Denissen
Moderator
Moderator
Posts: 7256
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Troubleshooting - Invalid Characters

Post by Erwin Denissen » Thu Aug 03, 2017 10:08 am

owen wrote:
Thu Aug 03, 2017 7:54 am
The invalid glyph "fraction" is blank/empty.
Well, that seems incorrect to me, so either provide the missing outline or remove the glyph.

Btw in FontCreator 11 I would expect the glyph to be placed in the Troubleshooting -> Incomplete Characters category.
owen wrote:
Thu Aug 03, 2017 7:54 am
Does the "Invalid Characters" filter get re-evaluated whenever a glyph is edited or do I need to run something like the validation wizard to update it?
It is re-evaluated automatically.
owen wrote:
Thu Jul 27, 2017 8:52 am
I trying to reuse some old ttf fonts that were created with old versions of FontCreator (a mixture of version 3.0 and 5.5). I was struggling to get a particular tool to accept them, so I tried loading them up in the latest (evaluation) version of FontCreator to see if it could flag up any issues with them. Straight away from launch the left hand filter tree included an "Invalid Characters" section under "Troubleshooting". This appears to include every character in the font.
Maybe it is a symbol font, but if you can't provide more information, we can't provide adequate support :?
Erwin Denissen
High-Logic
Proven Font Technology

owen
Posts: 3
Joined: Thu Jul 27, 2017 8:30 am

Re: Troubleshooting - Invalid Characters

Post by owen » Fri Aug 04, 2017 10:32 am

I agree the "fraction" glyph being blank/empty is odd. At the moment though I am just trying to understand what rules the "Invalid Characters" category is checking for, so that I can try and bottom out all the issues these fonts have.

The "fraction" glyph as you say is included in the "Incomplete Characters" section as it is empty, but it is also in the invalid section at the same time. It doesn't seem that being incomplete is sufficient for a glyph to be considered invalid as there are other empty glyphs in the font that have been put into the "Incomplete Characters" section without being put into the "Invalid Characters" section. Adding a small circle in the centre of the drawing area on the empty valid glyphs is enough for them to be automatically removed from the incomplete characters section, but it does not remove the "fraction" from the invalid section.

I understand if you are unable to provide much advice without a sample, I was just hoping you might be able to list some of the things that the "Invalid Characters" section is checking for. Thanks.

Erwin Denissen
Moderator
Moderator
Posts: 7256
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Troubleshooting - Invalid Characters

Post by Erwin Denissen » Fri Aug 04, 2017 11:02 am

Awkward left-side or right-side bearing is another thing.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests