AutoMetrics

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Thu Aug 24, 2017 9:27 am

I've been playing around with the AutoMetrics in the new version, but something doesn't work right.
When I run AutoMetrics it now messes up my composites. Before running it, every accent is nicely centered (or in its place).
Image

After running the tool they no longer are.
Image

This can't be undone either:
I tried running Autometrics with fixed side bearings and set them all to 100. The composites were messed up, but the original letters in the glyph edit windows looked fine.
Image

But when I hit Undo, the line of the right side bearing will jump back to where it was before, but on the left side there are now two lines, one at 100 and one at the original value. And the composites are still messed up, even after hitting Undo. I have to close the font and re-open it to get things back to normal.
Image

In 10.1 that didn't happen. No matter how often I ran AutoMetrics, the accents always remained where they were.

Erwin Denissen
Moderator
Moderator
Posts: 7002
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: AutoMetrics

Post by Erwin Denissen » Thu Aug 24, 2017 4:29 pm

That sounds like a bug to me. We'll look into this.
Erwin Denissen
High-Logic
Proven Font Technology

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Thu Aug 24, 2017 4:30 pm

Okay, thank you.

Erwin Denissen
Moderator
Moderator
Posts: 7002
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: AutoMetrics

Post by Erwin Denissen » Fri Aug 25, 2017 8:33 am

It seems version 10 failed to set the left and right side bearings for composite glyphs. We fixed that with version 11, which is why it behaves differently.

The undo issue is indeed a bug which will be solved with the next upcoming release.
Erwin Denissen
High-Logic
Proven Font Technology

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Fri Aug 25, 2017 12:41 pm

Hm, but if "differently" means that AutoMetrics now moves the diacritic marks of my composites, then I have a problem. Either I make all composites simple again to avoid that, or I have to manually fix all diacritics afterwards. Neither option really makes sense to me.

PJMiller
Top Typographer
Top Typographer
Posts: 568
Joined: Tue Jun 16, 2015 8:12 pm
Location: Sheffield, South Yorkshire
Contact:

Re: AutoMetrics

Post by PJMiller » Fri Aug 25, 2017 6:38 pm

I think I understand what is going on, but I may be mistaken so Erwin might want to comment on this.

The composite is made up of two glyphs positioned relative to one another. The user sets the relative position so that the accent or whatever looks correct and the program should strive to keep this relative position unchanged. If Auto Metrics adjusts the side bearings of either glyph then it will also move the relative position of the glyphs making up the composite.

I think the behavoiur of Auto Metrics 'should' be to keep the relative position of the two glyphs the same, as the user set it, but this might be difficult to achieve. It would mean changing the actual position of one of the glyphs to keep the relative position the same, this would be a lot of work because when adjusting the bearings of any glyph Auto Metrics would also have to check the composites using that glyph.

Perhaps the offset between the two glyphs could be stored and used for positioning but this would require a reference point on each glyph which doesn't change if the side bearings change.

This is probably a lot of programming work.

The situation is much better with FC 11 than FC 10. FC 11 leaves the side bearings of any composite which has the 'use this glyph's metrics' flag set. FC 10 used to ignore this flag and just set the bearings to what it thought appropriate. But FC 10 did keep the relative position the same whereas FC 11 doesn't.

Hope this helps. :D
Last edited by PJMiller on Fri Aug 25, 2017 10:14 pm, edited 1 time in total.

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Fri Aug 25, 2017 6:59 pm

Thanks for your explanations!
I don't know anything about programming, so I really don't know how difficult it would be.
PJMiller wrote:
Fri Aug 25, 2017 6:38 pm
FC 11 leaves the side bearings of any composite which has the 'use this glyph's metrics' flag set.
That's something I obviously haven't found out about yet. How do I set such a flag?

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7161
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: AutoMetrics

Post by Bhikkhu Pesala » Fri Aug 25, 2017 7:13 pm

Karin1610 wrote:
Fri Aug 25, 2017 6:59 pm
That's something I obviously haven't found out about yet. How do I set such a flag?
If you open a composite glyph, and double-click the base glyph, you will see the Composite Glyph Properties dialogue, which is where it is set.

If you used Complete Composite to create composite glyphs, the flag will usually be set already.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1709

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Fri Aug 25, 2017 7:21 pm

For some I used Complete Composite, for some I didn't. I'll look at that tomorrow.
Thanks for the hint!

Erwin Denissen
Moderator
Moderator
Posts: 7002
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: AutoMetrics

Post by Erwin Denissen » Fri Aug 25, 2017 8:45 pm

There is certainly something wrong with Auto Metrics, so here is another update:

32-bit:
http://www.high-logic.com/tmp/FontCreat ... 0.2401.exe

We'll officially release it early next week if it works as intended.
Erwin Denissen
High-Logic
Proven Font Technology

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Sat Aug 26, 2017 9:43 am

Thanks for providing this in 32bit for me!

The Undo works correctly now, but the diacritic marks still move. That's quite a hassle because there are so many composites that I'll have to fix manually, unless I make them all simple (which I don't really want).

I've also checked out what the "Use this glyph's metrics" does and I'm not sure I really understand this. I would have thought that, when the flag is set for the base glyph, the metrics should be the same as the base glyph's. But they aren't.
My O's side bearings are 57/114. All the O composites have that flag set for the base glyph, yet their bearings are 100/71.
Also, if I don't set the flag for any glyph, I can manually change the side bearings of the composites. I would think that now changing the base glyph's side bearings doesn't have any effect on the composite's anymore, but it does.
Do I just not understand this or is it not working correctly?

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Sat Aug 26, 2017 11:20 am

Duh, the different values for base glyphs and composites came from FC 10. I forgot that I ran AutoMetrics there before installing the new version.

I re-installed version 10 now, gave all glyphs fixed side bearings and installed version 11 again, so I could start fresh there. Running AutoMetrics now provides equal values for base glyphs and composites.
However, the diacritic marks still move, and what I described about not setting the flag "Use this glyphs's metrics" for any glyph still happens. Changing the base glyph's side bearings will change the composite's anyway.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7161
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: AutoMetrics

Post by Bhikkhu Pesala » Sat Aug 26, 2017 12:27 pm

From the Edit menu, use Select Composites. Tag them as ToDo.

Select the tagged glyphs, and make them simple, then complete composites.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1709

Karin1610
Posts: 62
Joined: Sun Jul 23, 2017 9:07 am

Re: AutoMetrics

Post by Karin1610 » Sat Aug 26, 2017 12:49 pm

Problem is, Complete Composites horizontally puts my diacritics in the correct position, but not vertically. They are all way too high, so I have to fix them anyway.

Erwin Denissen
Moderator
Moderator
Posts: 7002
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: AutoMetrics

Post by Erwin Denissen » Sat Aug 26, 2017 3:15 pm

Karin1610 wrote:
Sat Aug 26, 2017 9:43 am
Thanks for providing this in 32bit for me!

The Undo works correctly now
That is good to know!
Karin1610 wrote:
Sat Aug 26, 2017 11:20 am
However, the diacritic marks still move, and what I described about not setting the flag "Use this glyphs's metrics" for any glyph still happens. Changing the base glyph's side bearings will change the composite's anyway.
It should only happen if you include the composites in the selected list of glyphs. If you don't want that, then don't include them.

We realize the way you have to select glyphs is tedious, so maybe we can find a way to improve that so your issue is solved that way. Ideas ;-)
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests