Page 1 of 2

3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 6:07 am
by Jonne Haven
Erwin and company,

I noticed that 3 periods are no longer triggering the ellipsis. I have sent the project file to Erwin. I'm hoping it's some setting somewhere that's off.

Thanks,

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 10:17 am
by Erwin Denissen
It would help if you were a little more specific.

By default Word does replace three dots (...) with the ellipsis character (AutoCorrect), but other word processing software might not do this. I've just tested the font with Word, and it works just fine. Typing three periods results in the ellipsis.

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 10:24 am
by Jonne Haven
Yes, the ellipsis works with Word. I just tested it. However it does not work in FontCreator which is a problem because I can't properly kern it without it showing me the ellipsis. The ellipsis also does not work in the Test OTF window either.

Blessings,

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 10:28 am
by Erwin Denissen
It works just fine. For example to test kerning between ellipsis and question mark, either use:

/ellipsis/question

or

…?

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 10:34 am
by Jonne Haven
Erwin,

When I enter /ellipsis/question it does work. When I enter ...? it does not work.
Ellipsis.png
Ellipsis.png (4.93 KiB) Viewed 2506 times
Blessings,

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 11:12 am
by Jonne Haven
Erwin,

I tried uninstalling and reinstalling a previous version of Fontcreator 2402, with the same results to do with three periods not triggering an ellipsis. These seems to only happen in fontcreator. It works fine with Word and when I enter /ellipsis, but it does not work with 3 periods as it should within the program. I've tried an earlier version of my font with the same results.

I could use some help.

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:04 pm
by Erwin Denissen
I don't see any issue with the font. The ellipsis works just fine.

FontCreator will not turn three dots into an ellipsis. If that is what you expect, then that is a false expectation. We don't intend to add such "smart tricks" into FontCreator. If you wish to see the ellipsis, either type that character (…), or type /ellipsis

Please be aware the above … is a single character. Do try to copy and paste it to confirm this :lol:

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:07 pm
by Jonne Haven
I see,

I must have missed this all this time. My bad. Although this is not the forum for requests, it would be nice if the ellipsis with three periods did trigger an ellipsis. If not, that's fine.

Blessings and thanks!

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:08 pm
by Erwin Denissen
Jonne Haven wrote:
Sat Sep 09, 2017 12:07 pm
I see,

I must have missed this all this time. My bad. Although this is not the forum for requests, it would be nice if the ellipsis with three periods did trigger an ellipsis. If not, that's fine.

Blessings and thanks!

Jonne
Most professionals don't use Word, and I suspect they don't expect such magic. They would be confused if FontCreator tried to be smart this way.

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:11 pm
by Jonne Haven
Yes you are right, when I copy and paste the ellipsis from your post, it does work in Fontcreator...I'm just a bit fuzzy on how I can enter that character within FontCreator.

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:28 pm
by Erwin Denissen
A recently added gem:

First type /glyphname and then if that glyph also has a code point assigned to it, rightclick the preview area and select Copy input as text.

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:37 pm
by Jonne Haven
Erwin Denissen wrote:
Sat Sep 09, 2017 12:28 pm
A recently added gem:

First type /glyphname and then if that glyph also has a code point assigned to it, rightclick the preview area and select Copy input as text.
Thanks Erwin,

Works like a charm!

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:38 pm
by Bhikkhu Pesala
You could, of course, also add a standard ligature for period period period -> elipsis.

I use a couple of liga subs for Interrobang and Irony punctuation, which otherwise would probably not get noticed. Ellipsis is a fairly common replacement for Autocorrect, or some know how to type it with Alt+0133 …
Period to Ellipsis.png
Period to Ellipsis.png (2.68 KiB) Viewed 2474 times

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 12:49 pm
by Jonne Haven
Bhikkhu Pesala wrote:
Sat Sep 09, 2017 12:38 pm
You could, of course, also add a standard ligature for period period period -> elipsis.

I use a couple of liga subs for Interrobang and Irony punctuation, which otherwise would probably not get noticed. Ellipsis is a fairly common replacement for Autocorrect, or some know how to type it with Alt+0133 …

Period to Ellipsis.png
I would very much like to do this...I tried liga in the GSUB but couldn't get period period period to register...would you mind walking me through this?

Thanks Bhikkhu Pesala,

Jonne

Re: 3 periods not triggering the ellispsis

Posted: Sat Sep 09, 2017 1:08 pm
by Bhikkhu Pesala
Just do it in the Code Editor or use the + button to add a new substitution of:

period -> ellipsis

Then edit the input string to "period period period".
Code Editor.png
Code Editor.png (9.27 KiB) Viewed 2465 times