Version string doesn't display in installed font

Get help with FontCreator here. Please do not post feature requests or bug reports here.
harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Mon Sep 18, 2017 6:50 pm

Have other people encountered this problem? I'm unclear what in the font naming I've used violates the "naming table strictness".

I've tested with two fonts.
One named ShvetambariRudram2017 which even if I don't change anything as soon as I click OK to Font/Properties/Identification causes the Version string to disappear in Windows Font Viewer.

One named LeewoodRudram2017-U which if I click OK in Font/Properties/Identification and only change the version number then it still displays correct in Windows Font Viewer. But if I change the name to "LeewoodRudram2017" and click OK then the Version string disappears in Windows Font Viewer.

Thanks,
Harry

MikeW
Posts: 498
Joined: Mon May 20, 2013 2:51 pm

Re: Version string doesn't display in installed font

Post by MikeW » Mon Sep 18, 2017 7:52 pm

I cannot remember what version (major or minor) that had a bug about the naming fields. It was promptly rectified and is no longer present in any of the fonts I have made or modified.

Mike

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Mon Sep 18, 2017 9:07 pm

Erwin said:
There is room for another option in the Font page (Options Dialog).

The online documentation for the Tools/Options/Font menu:
http://www.high-logic.com/fontcreator/m ... _font.html
shows a whole lot of options one of which is "optimize name table" when saving font files.

But my version of FontCreator (Standard) on that menu only has the option "generate friendly glyph names".

Is this old documentation or are these font options (including optimize or don't optimize naming tables) that are available in the professional version of FontCreator?

Thanks,
Harry

Erwin Denissen
Moderator
Moderator
Posts: 7000
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version string doesn't display in installed font

Post by Erwin Denissen » Tue Sep 19, 2017 9:27 am

harryspier123 wrote:
Mon Sep 18, 2017 9:07 pm
Erwin said:
There is room for another option in the Font page (Options Dialog).
On second thought, we're not going to implement a work-around. Windows fonts viewer can't cope with a valid font file, so I suggest you contact Microsoft and ask if they can fix their software.
harryspier123 wrote:
Mon Sep 18, 2017 9:07 pm
The online documentation for the Tools/Options/Font menu:
http://www.high-logic.com/fontcreator/m ... _font.html
shows a whole lot of options one of which is "optimize name table" when saving font files.

But my version of FontCreator (Standard) on that menu only has the option "generate friendly glyph names".

Is this old documentation or are these font options (including optimize or don't optimize naming tables) that are available in the professional version of FontCreator?
The most recent documentation can be found through this page:
http://www.high-logic.com/support/product-support.html

But even that version isn't updated to the latest release.
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest