Version string doesn't display in installed font

Get help with FontCreator here. Please do not post feature requests or bug reports here.
harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Version string doesn't display in installed font

Post by harryspier123 » Sat Sep 16, 2017 4:11 am

In a font I've edited in Fontreator In the Font Properties menu I've put in a font revision of 1.000 and clicked the "Generate the following naming fields automatically" so it creates a Version string of "Version 1.00;September 15, 2017;FontCreator 11.0.0.2408 64-bit"

I install the font but when I examine it in the font viewer (Windows 7) It doesn't show the version string. (The other installed fonts all show a version string).

I know the font was installed because as a check I copied the installed font to a directory and then open it in FontCreator and examine the Font revision which is "1.000" and the version string which is "Version 1.00;September 15, 2017;FontCreator 11.0.0.2408 64-bit. However this doesn't display when I open the font file in the font viewer.

Any ideas of why the version string isn't displaying in the font viewer. This is important for me because I'll be revising and sending different versions almost on a daily basis to users to install and give feedback.

Thanks,
Harry

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7252
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Version string doesn't display in installed font

Post by Bhikkhu Pesala » Sat Sep 16, 2017 4:22 am

Windows Font Viewer always shows the installed font, not the one that you open from Windows Explorer. Make sure that you uninstall the old version before installing the new version.

I use MainType to manage my fonts, and delete old versions from the MainType database after uninstalling them. I export fonts to a temporary folder, copy them to my OpenType fonts folder, and always install the new version from there.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT8.0 @ Win10 1709

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Sat Sep 16, 2017 4:45 am

Hi Bhikkhu,

I did uninstall the old font before installing the new font and viewed the installed font directly with font viewer but still the version string did not display. I then copied the installed font to a directory and opened it in FontCreator and double checked that there was a version string and there was.

Thanks,
Harry

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Sat Sep 16, 2017 5:32 am

I just downloaded the free version of Maintype and when I open the installed font in Maintype and under font properties the version number is there and correct. But for some reason there is no version string displayed in windows font viewer.

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7252
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Version string doesn't display in installed font

Post by Bhikkhu Pesala » Sat Sep 16, 2017 8:08 am

Maybe it's a Windows version problem. I am using the latest Windows 10.
Windows Font View.png
Windows Font View.png (6.18 KiB) Viewed 465 times
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT8.0 @ Win10 1709

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Sat Sep 16, 2017 1:53 pm

It is only this font that the version doesn't display in windows font viewer. All other fonts on my computer display the version string in windows font viewer.

Harry

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Sat Sep 16, 2017 3:03 pm

OK I see a little clearer whats going on.

The original font I'm editing was created in Fontographer years ago and for some reason it doesn't display a version string in windows font viewer.

When I edit this font in FontCreator it still doesn't display a version string in windows font viewer.

But if I open the font in FontForge and then generate a font from it, it will then display the version string in windows font viewer. And if I now edit this font generated in FontForge in FontCreator it will continue to display the version string in windows font viewer.

So it appears there is some issue in the original font that prevents the version string being displayed in windows font viewer that FontCreator doesn't catch when it generates a new font from the original.

Thanks,
Harry

Erwin Denissen
Moderator
Moderator
Posts: 7170
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version string doesn't display in installed font

Post by Erwin Denissen » Sat Sep 16, 2017 4:47 pm

Bhikkhu Pesala wrote:
Sat Sep 16, 2017 4:22 am
Windows Font Viewer always shows the installed font, not the one that you open from Windows Explorer. Make sure that you uninstall the old version before installing the new version.
I totally agree. Do reboot your computer and then try again. It will work.
Erwin Denissen
High-Logic
Proven Font Technology

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Sun Sep 17, 2017 1:11 am

Hi Erwin,

I wish it were that simple. The problem only happens with this font and uninstalling, installing and rebooting doesn't help. All other fonts I can edit the Font Identifier information and it still appears correctly in Windows Font Viewer.

With this font as long as I don't go into the Font/Properties/Identification menu and don't click OK I can still edit the font and export it and the Windows Font Viewer displays the identification information correctly:
Fontname: ShvetambariRudram2017
Version: Version 3.00;September 16, 2017;FontCreator 11:0.0.2408 64-bit
OpenType Layout Digitally Signed, TrueType Outlines

But if I go into the Font/Properties/Identification menu and click OK (even if I don't change anything in the menu) and then export the font then the Version string and the Opentype and Digitally Signed information disappears and it displays:
Fontname:ShvetambariRudram2017
TrueType Outlines

But FontCreator still has the correct information in the Font/Properties/Identification menu. Also if I now open the font that is now not displaying correctly in Windows Font Viewer in FontForge and regenerate it from FontForge it then again displays correctly in Windows Font Viewer.

Thanks,
Harry

Erwin Denissen
Moderator
Moderator
Posts: 7170
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version string doesn't display in installed font

Post by Erwin Denissen » Sun Sep 17, 2017 1:44 am

Custom naming fields might be the cause. Otherwise send the font file to me so I can look into this.
Erwin Denissen
High-Logic
Proven Font Technology

harryspier123
Posts: 17
Joined: Tue Aug 22, 2017 2:28 pm

Re: Version string doesn't display in installed font

Post by harryspier123 » Sun Sep 17, 2017 3:48 am

I think I'll have to send the font file to you but I don't see how to do an attachment in a private message. Is there an email address to send it to?

Thanks,
Harry

Erwin Denissen
Moderator
Moderator
Posts: 7170
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version string doesn't display in installed font

Post by Erwin Denissen » Mon Sep 18, 2017 7:07 am

We've received the font files and looked into this problem. To us it looks like a bug in Windows font viewer. It is probably too strict in accepting optimized name tables. We've always optimized the name table to save some bytes, and nothing in the specs prevent us from doing this.
Erwin Denissen
High-Logic
Proven Font Technology

PJMiller
Top Typographer
Top Typographer
Posts: 580
Joined: Tue Jun 16, 2015 8:12 pm
Location: Sheffield, South Yorkshire
Contact:

Re: Version string doesn't display in installed font

Post by PJMiller » Mon Sep 18, 2017 5:21 pm

So the question is, how many bytes does it save and how much incompatibility does it cause ?

With hard disks and memory growing ever larger is it worth a possible incompatibility to save a few bytes ?

Erwin Denissen
Moderator
Moderator
Posts: 7170
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version string doesn't display in installed font

Post by Erwin Denissen » Mon Sep 18, 2017 5:57 pm

In this case it would be 1164 versus 975 bytes, so right now we save 189 bytes.
Erwin Denissen
High-Logic
Proven Font Technology

Erwin Denissen
Moderator
Moderator
Posts: 7170
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Version string doesn't display in installed font

Post by Erwin Denissen » Mon Sep 18, 2017 6:07 pm

There is room for another option in the Font page (Options Dialog).
Erwin Denissen
High-Logic
Proven Font Technology

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest