Weird behaviours under Windows 10

Get help with FontCreator here. Please do not post feature requests or bug reports here.
Post Reply
david2017
Posts: 6
Joined: Mon Nov 06, 2017 3:07 pm

Weird behaviours under Windows 10

Post by david2017 » Mon Nov 06, 2017 3:41 pm

Hi !

I have a weird problem with a custom font installed on Windows 10. It is a font created many years ago and that we continually update with FontCreator since then. Its is used to display traffic signs in a CAD/GIS environment. On earlier version of Windows, prior to 10, there had not been any problem at all. But since we installed our font on a Windows 10 computer, weird behaviors happened such as:
  1. When we call a unique character (glyph) with his code-point number in a CAD software, the wrong character is displayed. For instance in our font, the stop sign has the code 10101. Under Windows 7, where I use that code, it shows the stop sign. But under Windows 10, it displays a parenthesis. Why?
  2. Also, unknown characters that are not in the font now appear in the characters list in all Windows software like parenthesis, numbers, geometric shape. None of those characters are included in our font when opened in FontCreator !
Am I the only one facing these kind of problems under Windows 10?

Is there any workaround?

David

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7159
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Weird behaviours under Windows 10

Post by Bhikkhu Pesala » Mon Nov 06, 2017 4:17 pm

It does not sound like a bug in FontCreator. Perhaps a bug in your font.

It seems that Windows 10 is treating it as a Symbol font, instead of a Unicode font.

Are you able to share the font file or FontCreator Project file?
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1709

david2017
Posts: 6
Joined: Mon Nov 06, 2017 3:07 pm

Re: Weird behaviours under Windows 10

Post by david2017 » Mon Nov 06, 2017 6:00 pm

I forgot to mention that some characters are correct when i am querying them using the code-point value but most are not. I have over 1500 characters in this font. Correct me if I'm wrong but I don't think Windows 10 could ever treat my font as a Symbol font because of its size?

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7159
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Weird behaviours under Windows 10

Post by Bhikkhu Pesala » Mon Nov 06, 2017 6:19 pm

Without the font, we can only guess what the problem might be.

Send it to Erwin if you don't want to attach it here.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1709

david2017
Posts: 6
Joined: Mon Nov 06, 2017 3:07 pm

Re: Weird behaviours under Windows 10

Post by david2017 » Mon Nov 06, 2017 6:24 pm

Who's Erwin? :)

Erwin Denissen
Moderator
Moderator
Posts: 7000
Joined: Fri Oct 04, 2002 12:41 am
Location: De Bilt, The Netherlands
Contact:

Re: Weird behaviours under Windows 10

Post by Erwin Denissen » Mon Nov 06, 2017 6:47 pm

Dunno :lol:
Erwin Denissen
High-Logic
Proven Font Technology

david2017
Posts: 6
Joined: Mon Nov 06, 2017 3:07 pm

Re: Weird behaviours under Windows 10

Post by david2017 » Mon Nov 06, 2017 7:29 pm

here is the font attached to my post

Hope someone will be able to help me on this !

I submit also 2 pics, one showing the font in Win7 and the other on Win10. Same font but two different output. Same code-point also, the 10101.

Font in WIN10 environment:
win10.png
win10.png (19.99 KiB) Viewed 138 times
Font in WIN7 environment:
WIN7.png
WIN7.png (44.46 KiB) Viewed 138 times

[font removed]

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7159
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Weird behaviours under Windows 10

Post by Bhikkhu Pesala » Mon Nov 06, 2017 7:54 pm

The Stop Sign is mapped to Dingbat Right Curly Bracket, which is what I assume that you're seeing in your software, which must be using a substitute font.
Stop Sign Arete.png
Stop Sign Arete.png (5.9 KiB) Viewed 135 times
The Font Test Window matches what I see with the Test font in Serif PagePlus, which seems to be correct.
Test Font in PagePlus.png
Test Font in PagePlus.png (25.67 KiB) Viewed 135 times
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1709

david2017
Posts: 6
Joined: Mon Nov 06, 2017 3:07 pm

Re: Weird behaviours under Windows 10

Post by david2017 » Mon Nov 06, 2017 8:00 pm

So.....

Why does the glyph 10101 beeing replaced by a substitute one? Is there any reason?

Thanks for you help

Bhikkhu Pesala
Top Typographer
Top Typographer
Posts: 7159
Joined: Tue Oct 29, 2002 5:28 am
Location: Seven Kings, London UK
Contact:

Re: Weird behaviours under Windows 10

Post by Bhikkhu Pesala » Mon Nov 06, 2017 8:19 pm

Maybe ask Microsoft or the authors of your CAD software?

It works OK in LibreOffice on Windows 10.
My FontsReviews: MainTypeFont CreatorHelpFC11.0 Pro + MT7.0 @ Win10 1709

david2017
Posts: 6
Joined: Mon Nov 06, 2017 3:07 pm

Re: Weird behaviours under Windows 10

Post by david2017 » Mon Nov 06, 2017 8:23 pm

Well ! Thank you for your help. I'll try to find a solution to all of this

Regards

David

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests